PDA

View Full Version : Very strange problem



lsdi
01-09-2002, 10:44 AM
Im trying to make a landscape so I do this:


a plane with 0 of elevation, simulating sea.

a Island (loaded from height map) elevation starting at -5;


like this:

Island _____
/ \
/ \ Plane
-------------/---------\------------------------
/ \

They´re both textured.

The problem (sorry about bad english):

intersection== where plane touchs insland

when Im more then 5.0f far from the "intersection" its very strange, its not smooth, like some big polygons and lines.
if the island dont touch the plane. everything its ok.

Island size(elevation): about 300f
plane size: about 5000f
texture size: 256x256

lsdi
01-09-2002, 11:26 AM
here:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~~~~~~~~____~~~~~~~~~~~~~~~~~~
~~~~~~~~~/~~~~\~~~~~~~~~~~~~~~~~
~~~~~~~~/~~~~~~\~~~~~~~~~~~~~~~~
@@@@@@@/@@@@@@@@\@@@@@@@@@@@@@@@
~~~~~~/~~~~~~~~~~\~~~~~~~~~~~~~~

Korval
01-09-2002, 11:29 AM
People who aren't using fixed-width fonts can't understand what you just drew in ASCII text. Put them in a code block so we can understand what's going on.

lsdi
01-09-2002, 12:08 PM
Island: -----------
/ \ Plane:
-----------/-------------\--------------
/ \


sorry. http://www.opengl.org/discussion_boards/ubb/smile.gif

Elixer
01-09-2002, 12:11 PM
Perhaps a link to a picture of the problem?
(and don't make it a 1MB TGA file either ) http://www.opengl.org/discussion_boards/ubb/smile.gif

01-09-2002, 12:49 PM
What are your near and far clipping plane values?

lsdi
01-09-2002, 03:07 PM
I can send a screenshot (jpg) of the problem via email.

Thanks a lot.