PDA

View Full Version : GLut not found



Adriano
05-07-2001, 11:38 PM
Hi there,

I have installed the OGL and GLut in my Home-PC, exactly as I have done in my PC in the Laboratory, which is working fine... but in my HomePC the VC++ debuger can't find the GLut anyway.

fatal error C1083: Cannot open include file: 'GL/glut.h': No such file or directory

I have included it in the MVC++ Menu: Build -->Settings --> Link --> GLut.lib GLut32.lib OpenGL32.lib GLu32.lib GLaux.lib .

But it even doesn't work. So, any hints ?
Thnx in advance. ....|:0).
Adriano

05-08-2001, 12:08 AM
The error is that you do not have glut.h in your GL include directory and not a linker error. My guess is that you have it in the normal include directory but it should be in the GL subdirectory.

You should also link to only one glut library for windows is glut32.lib standard. I would also avoid mixing glut and glaux.

ffish
05-08-2001, 12:10 AM
You should have a glut.h header file lying around somewhere from when you downloaded glut.zip. Copy glut.h to (on my computer - yours should be the same or similar) C:\Program Files\Microsoft Visual Studio\VC98\Include\GL\

The include directory is the standard system include directory, GL is the "GraphicsLibrary" specific directory. You should find other files in there like gl.h, glu.h, glaux.h and any others you might choose to install.

Alternatively, you could just add the directory where glut.h is to your project settings. I haven't done this on VC++ but it's probably similar to Linux: -I/some_dir/hierarchy/somewhere/

This is a flexible way to set up custom include paths for different projects.

Hope that helps.