PDA

View Full Version : Why OpenGL always render in software mode on my ATI Rage 128



Sanya
01-11-2001, 11:42 PM
Thanks all for u help!
But i have another question.
I have ATI Rage 128 Pro and WindowsNT
My renderer always is "GDI Generic" even if i set PFD_GENERIC_ACCELERATED flag and reset it. And it working so slow...
What wrong?
(sorry for my english http://www.opengl.org/discussion_boards/ubb/smile.gif

static PIXELFORMATDESCRIPTOR pfd =
{
sizeof(PIXELFORMATDESCRIPTOR), 1, PFD_DRAW_TO_WINDOW |
PFD_SUPPORT_OPENGL | PFD_DOUBLEBUFFER|
PFD_GENERIC_ACCELERATED, PFD_TYPE_RGBA,
16,0,0,0,0, 0,0,0,
0,0,0,0,0,0,
16,0,0,
PFD_MAIN_PLANE,
0,0,0,0
};

Bob
01-12-2001, 01:26 AM
The PFD_GENERIC_ACCELERATED should not be set if you want to use hardware specific drivers.

Also make sure you are not using features that is not available in your hardware. For example, the use of an accumulation buffer will cause most of todays consumer-level hardware to fall back to software, because it's not supported in hardware.

coco
01-12-2001, 09:44 AM
If you get "GDI Generic" there's no doubt you are using Microsoft's software implementation.
Just read in another forum PFD_GENERIC_ACCELERATED should be used if your card has an OpenGL ICD (a full opengl driver), and not used if the card has an MCD driver (mini driver). Still I'm 99% shure the ATi 128 has a Full OpenGL ICD so you must set the flag. Check this things (may apear trivial):
-download the latest ATi drivers
-your pfd structure looks perfect
-be sure your resolution is not too high for your card to do 3D (a 16mb card probably wont do 3D in 1280x1024x32bits or higher, for example).

Elixer
01-12-2001, 09:52 AM
I don't think the PDF is the problem. Are you mixing gdi calls? If so, I think that makes it revert to software mode.

I am using a Rage 128 in one of my machines, and it does have a full ICD, and I am using the latest "special purpose" drivers.