PDA

View Full Version : ERROR: GL 1.1 and up are not supported



duck bong
04-26-2006, 12:58 AM
I'm a beginner programmer trying to get my first shader to run in my OpenGL application.

I have included <GL/glew.h> (before glut), installed the dll file into SYSTEM32, the glew32.lib in LIB and glew32.h etc in include. I have also set linker to read glew32.lib

If I run this code in my main function to identify the problem:

/************************************************** ***********/

int main(int argc, char *argv[])
{
glutInit(&argc, argv);

glewInit();
GLenum err = glewInit();
if (GLEW_OK != err)
{
fprintf(stderr, "Error: %s\n", glewGetErrorString(err));
}
fprintf(stdout, "Status: Using GLEW %s\n", glewGetString(GLEW_VERSION));

...so on ------

it returns the error message:

////////////////////////////////////////
ERROR: GL 1.1 and up are not supported
/////////////////////////////////////////

I need your help. Really thanks in advance.

Relic
04-26-2006, 01:55 AM
Answered in the shading language forum. (Do not double post.)