PDA

View Full Version : Updating/Replacing opengl drivers for specific hardware



chaospixel
05-10-2001, 01:40 AM
Hiya,

I have a very old, very crudy 3DLabs permedia 2 video card with some hardware acceleration.

The existing opengl drivers for this card do not implement alpha blending at all. however, I am confident that I can emulate this with software rendering.

I would like to update the existing driver or create my own driver that uses the hardware where it exists and emulates where necessary. The DirectX drivers for the card seem to get this right in places...

Any suggestions on where to even look for information would be usefull as I have no idea how to update or write an opengl driver http://www.opengl.org/discussion_boards/ubb/smile.gif

ffish
05-10-2001, 04:02 AM
I wouldn't even try to write a driver unless you had full hardware specs, a simple card, you knew what you were doing and you had a lot of time on your hands http://www.opengl.org/discussion_boards/ubb/smile.gif If you can't find an updated driver and you want software emulation, what about writing your own library and linking that into your programs? That would probably be the easiest solution.

Good luck!

arieb
05-11-2001, 03:44 PM
find your opengldrivers in the registry and replace the DLL name to opengl32.dll
(just check to see if opengl32.dll is in your system...)

chaospixel
05-16-2001, 06:20 AM
thanks for the advice http://www.opengl.org/discussion_boards/ubb/smile.gif

actually, the simplest from that point of view would be to use DirectX as that manages the blending just fine. it's only the OpenGL driver that duffs it up.

The thing is that I want to improve the visual appearance of existing applications on my system (like my Playstation Emulator that only supports OpenGL)

If I really just wanted a better looking system though I could go out and buy a better graphics card. I just like graphics coding and I haven't had a chance in years - so this is to be a turning point http://www.opengl.org/discussion_boards/ubb/wink.gif

The general stategy is basically to pass everything back to the existing driver and just write code for the blending, which I'm fairly confident I can do.

The thing is that I don't know how to write an OpenGL driver, what API must I support? what are the requirements?

thanks again for the support