PDA

View Full Version : OpenGL.DLL ??



DLink
01-10-2001, 01:54 PM
This is strange... I'm running OpenGL through Visual studios 6.0 on Windows 98...

I know I have all the appropriate DLL's on my system and in the appropriate places, and I've also linked to the correct libraries in my project setup, but a program that I copied out of a recent book doesn't run... It crashes after opening a Glut window saying "OPENGL.DLL Not Found"...

This seems very strange to me, since I only know of the existence of OpenGL32.dll!

Does anybody know what this could mean?

Aldacron
01-10-2001, 04:35 PM
Are you using the OpenGL SuperBible version of GLUT? Regardless, it sounds like the version of GLUT you are using was compiled to load the SGI OpenGL implementation. Just download the latest, precompiled GLUT binaries and link to those instead.

humberto
01-11-2001, 02:41 PM
Hi DLink,

I have a Vc++ 5.0 somethings can be different but I think I can help you.

Go to Project - Settings - Link (Tab)
Now there is an edit window labeled "Object/library modules" you should rename opengl.lib to opengl32.lib.
This will make your compile look for opengl32.dll instead of opengl.dll.

coco
01-11-2001, 07:22 PM
The exact problem is what Aldacron describes. You should either download the now unsupported SGI OpenGL for Windows sdk, or replace your GLUT version (all .lib, .h, .dll,) with the current version.
Then in VC, Project->Settings->Link, in the Object/Libraries replace glut.lib with glut32.lib,glu.lib with glu32.lib , and opengl.lib with opengl32.lib.