PDA

View Full Version : Having troubles when I run my program



Nomaden
07-21-2000, 09:50 AM
USing NeHe's tutorial I have just typed in all of lesson 1, but when I run it there is some warning/error :"W8060 possibly incorrect assignment"

Is that because I use C++ builder, as discused in my other thread ?

the lines it is warning about says :

if (!(hRC=wglCreateContext(hDC)))
{
KillGLWindow();
MessageBox(NULL,"Can't create a GL rendering context","ERROR",MB_OK|MB_ICONEXCLAMATION);
return FALSE;
}

If it is due to me using builder, then what can i do to make it work in builder ?

The program works though.. so it's not like i can't live with these warnings(4 og them) but I would like them to be gone =)



[This message has been edited by Nomaden (edited 07-21-2000).]

blide
07-21-2000, 08:36 PM
U are right, it is builder specific...welll i dont know bout others but i know msvc++ dfont care. Its actually helpful though...the most commonn programming error...: when u want:
if(a == b)
but u put:
if(a = b)
!!!!!
this thing warns u about assignments in if statements!!! i would love for msvc++ to do that, i have made that mistake so many times!

ngill
07-21-2000, 09:11 PM
if you REALLY care... then what you could do is try to find a #pragma option or something? I know that you can disable warnings when you do implicit conversions from one data type to another... so, maybe there is an option for something like this?

Nomaden
07-21-2000, 09:57 PM
Okay guys.. Thanks. I will try and find some way to turn these warnings of, and if I can't find them, then my boss is going to buy me MSVC++.. hehe

cya