PDA

View Full Version : Problem with GLUT/Bloodshed



JtheKing
11-05-2001, 11:12 AM
I swear this will be the last post on my problems with this. You can scroll down the list of topics in the last two weeks and you will see 10 or so messages from me about problems getting my programs to build. I downloaded the Bloodshed compiler and set it all up, and yet i STILL get build errors. For whatever reason compilers will not find my glut32.lib file. I've tried 3 different downloads of it, yet with the same results. Bloodshed gave me this printout of the error:

"Your disk may be too full to complete the link. Free up some space and try the link again. The error may be a result of trying to link over a network. Some networks do not fully support the memory-mapped files used by the linker. Try linking on your local disk to see if that fixes the problem.
There may be a bad block on your disk. "

I have alot of free space on my hard drive, so that is not the problem. I am on a "network" with my roommate, but the ONLY thing we share is an internet connection so that cannot be it(besides my computer would build these programs 3 weeks ago). I use win2k, and my computer is set up with an administrator account, and then a "personal" account. I use the "personal" account. I don't know if that has anything to do with it because i know NOTHING about networking. Any ideas anyone? please? I will not have a class next semester that will allow me to use their computers, so unless I get this fixed I will not be able to write opengl programs!!

dorbie
11-05-2001, 10:49 PM
You don't need glut for OpenGL, you can go the win32 route or whatever platform you are on (I'm not sure which you are on, what the heck is bloodshed)?

That said, where is the .lib?
Standard compiler linkage is -L<directory> to get it to look in a directory for a library file, so unless you've put the glut library in the appropriate system directory the linker will not find it without a -L to tell it where to look for user added libraries.

dorbie
11-05-2001, 11:01 PM
OK I now see you are clearly on windows, '32' is a giveaway. You also need to find the .dll for dynamic linking unless you're working with a static library. I'm not sure what the link options for bloodshed are. You should be able to add directories in the GUI. If this is too hard throw the glut library in the windows system directory and the compiler will find it. That's standard practice on Windows. Again, if this doesn't work you may be missing the .dll if it's dynamic and you need that so that's another potential source of the problem.

DFrey
11-06-2001, 04:56 AM
Again, it sounds like you have an incompatible lib file. Just download the GLUT source and build it. That will make a lib file you can use.

JtheKing
11-06-2001, 08:31 AM
Well that would make sense(incompatible file), but I've downloaded it 3 different times, and saved the file from a lab computer twice. Surely every single one of them is not incompatible! I will try building it like you say though.

Brent Fogarty
11-06-2001, 11:04 PM
It can't find it because you haven't told it to link to it, check out this post
http://www.opengl.org/discussion_boards/ubb/Forum2/HTML/006176.html

JtheKing
11-07-2001, 08:46 AM
I had linked to it, so that isn't the problem. I uninstalled Bloodshed and put Visual Studio(i have a student-version that is only the C++ version) back on. I'm following all the steps, and it is set up exactly like it is on the lab computers at my school. STILL doesn't work. I am linking the file so that is not the problem. It gives the same error about glut32.lib. I am going to give up messing with it. I've wasted enough time with it already!

11-07-2001, 09:45 PM
Make sure the link to the library is at the highest point of the link hierarchy...you may have a higher-priority link to some crappy old version of the library.

mikael_aronsson
11-07-2001, 11:21 PM
Hi !

If I am not 100% wrong here, you need a .a library not a .lib file as Bloodshed is using mingw32 gcc compiler, I belive there is a tool included to create a .a import library from the dll file included.

Mikael

kha
11-08-2001, 01:56 AM
I had quite a hard time setting up mingw 32 for OpenGL. Right now I am able to compile all the tutorials from NeHe. And I have started writting my own code. But it was quite a hell getting through this. I do not use Glut since it doesn't seems to be hardware accelerated. I am using the template from NeHe and add my code in it.
If you want me to help do not hesitate to drop me an email (kha at free dot fr) I will guide you.

kha

zed
11-08-2001, 11:58 AM
>>Well that would make sense(incompatible file), but I've downloaded it 3 different times, and saved the file from a lab computer twice. Surely every single one of them is not incompatible! I will try building it like you say though<<

that version of the library is incompatible with your compiler. u need to build the glut libraries with your compiler.
eg with vc if u use a dll built with vc6 with your version say vc5 u will get the same error (disk full)

kha
11-08-2001, 04:26 PM
If it is really glut you want I found some libraries that actually works

You can find them here http://www.openrpgs.com/downloads/other/page.php

Of course you will have to put glut32.def and libglut.a in your compiler lib repertory, glut.h in your compiler include directory and glut32.dll in your os system directory.

Works fine for the most.

You can test it with the code in the tutorials of Gamecoding UK
http://www.openrpgs.com/articles/showarticle.php?article=2001/apr/opengl

It works fine.

HTH Kha