View Full Version : What in the world am I doing wrong??!!

09-05-2002, 05:58 PM
Sigh. I know everyone is going to shoot theirself cause I'm asking this since it has been asked 1000's of times, but I'm getting the famous "glut32.lib: invalid file or disk full" error when i try to build a program. I've tried everything that people in the past were told to do on here(re: searched old posts) to no avail. I had the same problem last fall, and none of the advice given to other people with the same problem worked then either. I finally got it working by just dumping every needed file in the same folder as my code, but that doesnt even work this time. I have formatted since last fall, and didn't need a C++ compiler until now, so I just recently installed it. I use Visual C++ 5.0 and have Windows 2000. It is the exact same setup that I used last fall. I have tried a number of the glut/opengl files from different sites making sure it wasn't just a bad file that I got, but got the same error with all of them. It doesn't matter if I add the file to be linked in the project settings or not--I still get the same error.

Can anyone tell me if there is a glaring error in what I'm doing, or if there is something I'm forgetting to do? I've seemingly tried everything but it just won't work! I again apologize for asking this question, cause it appeared to have been asked billions of times. Just nothing works!

Leyder Dylan
09-05-2002, 06:59 PM
Your file is damged, try another one. Ex : search the same file in another website.

09-05-2002, 08:16 PM
I'll try again, but I've used files from 2 or 3 different places... sigh....

Originally posted by Leyder Dylan:
Your file is damged, try another one. Ex : search the same file in another website.

09-06-2002, 06:41 AM
Rebuild the glut source code itself. It sounds like you are trying to use a MSVC++ 6.0 lib with MSVC++ 5.0. So rebuild the glut source code, and use the lib it produces (make sure that lib generation is enabled too).

09-06-2002, 06:46 AM
If u didnt find the problem you should check user permission(s). Or check READ ONLY attributes in the files you are running, a friend of mine had something like that. Good luck cause u'll need it. =\