PDA

View Full Version : easy to understand opengl engine anyone?



Linked
02-15-2002, 07:21 PM
I am new to open gl I need an easy to understand opensource ogl engine... anyone got a favorite or something? thanks.

Korval
02-15-2002, 08:04 PM
If you're new to OpenGL, an "engine" is the last thing you need to look at. Check out http://nehe.gamedev.net/.

Linked
02-15-2002, 10:22 PM
thanks, my main goal (btw) is to set up a glide to open gl & D3d and vice versa wrapper mainly for my favorite game Wulfram 2
based in Glide, idle for a few years... it's being upgraded now but d3d wont be out for like a year as there is only one programmer writing it. awesome free game, www.wulfram.com (http://www.wulfram.com) come play, and get whooped up on ;) btw it is a tank game, requiring strategic planning and linear yet 3d fighting styles. if anyone wants to help out that would be appreciated it... for there are no working glide wrappers out compatible with geforce cards, and most people have ge force 2s or +

elimin8tor
02-16-2002, 03:31 AM
Originally posted by Linked:
most people have ge force 2s or +

Oh, how I'd love to have a Geforce 2, 3 or even 4 in a few weeks.... http://www.opengl.org/discussion_boards/ubb/wink.gif

Linked
02-16-2002, 07:54 PM
Why is that?

elimin8tor
02-17-2002, 08:12 AM
well come in, isn't it always the same? You buy a new system and then one or two years later it is totally outdated?
My Geforce256 is good enough, but a nice Geoforce4 would be nice...

Acid-Chris
02-18-2002, 10:22 AM
Originally posted by elimin8tor:
well come in, isn't it always the same? You buy a new system and then one or two years later it is totally outdated?

Ha!
if you buy a system, it is already outdated in the next month!!

many programmers forget very often that not everyone owns a high-end pc. :-(

Nothing
02-18-2002, 10:32 AM
As far as Glide -> OpenGL wrappers are concerned, there are already a hole load of them available (some even come with source).

You should have a look at:
www.glideunderground.com (http://www.glideunderground.com) (in the files section)
www.voodoofiles.com (http://www.voodoofiles.com)

Hope that helps.

Linked
02-18-2002, 11:01 AM
I appreciate your urls, but trust me... this is a last resort... I have scoured the net looking for ANY tye of wrapper able to be used with the gilde_2x.dll... in vein. all the glide wrappers are at least 3 years old... made for ati cards made between 97 and 2000 if your lucky. ge force(1+)s are totally not supported... http://www.opengl.org/discussion_boards/ubb/frown.gif thanks for the try though. Although if anyone can find me the newest version of XGL_200... I can't seem to find anything above XGL_200 v. 0.04a... voodoo files and the other url dont have them and I have spent hours trying to find them.

yall are great .. thanks(excuse the southern-speech... no accent... but I got it down pretty well when I make fun of some hicks :P http://www.opengl.org/discussion_boards/ubb/smile.gif )

Linked
02-18-2002, 11:06 AM
... Also, anyone that wants to help me try... the help would be appreciated... I am still a newbie... about a weeks worth of experience... I am to the point where I can put soem triangles on the screen LOL, laters