PDA

View Full Version : auugh! can't use openGL -- gl newbie



beoch
07-14-2000, 08:42 AM
The problem is not my code, it's just getting my system set up properly. I downloaded the latest glut dlls and libs (for win32) but I am still getting an error. But the problem is with gl.h. The compiler doesn't understand what WINGDIAPI is. Did I screw up somewhere, leave something out of my project settings, or do I need to download some newer files?

Help please!

Thanks,
Chris

07-14-2000, 09:09 AM
include windows.h before gl.h

beoch
07-14-2000, 09:19 AM
That makes so much sense it's scary. But I would think that gl.h would have included windows.h -- seeing how it uses stuff defined in it and all.

Oh well, such is life. Thanks again!