PDA

View Full Version : Link problem with 3ds MAX 4.2



Zemedelec
07-27-2002, 08:28 AM
Hello, I have a quick question about problem I have - I'm writing Export plug-in for MAX 4.2 and it can't link because of missing 'ClasDesc::GetRsrcString' thing. How is that possible? Autodesk own .LIBs are wrong?! I have no clue, because all samples do not compile too...
What is this to do with OGL..? Well, I love OGL, but before I am able to finish that exporter I could not start writing the renderer, so please if somebody have any idea - post it!
Thanx!

Deiussum
07-28-2002, 09:18 AM
Ok, it's been awhile since I've done anything with the Max SDK, but is "ClasDesc" your own class derived from one of the Max SDK classes? I seem to recall that they had some abstract classes you could derive your own from for things like eventing callbacks, etc. If the base class has pure virtual functions, you need to implement those functions in your derived class if you expect to be able to instantiate it.

Zemedelec
07-30-2002, 01:23 AM
Well, I should said that I'm not *such* kind of beginner... http://www.opengl.org/discussion_boards/ubb/smile.gif)
The problem is that the function I mentioned is not pure virtual (i.e. it is not a part from ClassDesc overridable interface). I that was the problem, because it said that that function is not implemented, and I was sure it is...
However when I switched to MSVC 7.0 all problems gone, somebody said it was because of MSVC 6.0 stupid #define-s that change from version to version, and LIBs got obsolete very soon....
But thanks, I thought nobody replies here... http://www.opengl.org/discussion_boards/ubb/smile.gif