PDA

View Full Version : compile problems



CHEF
11-02-2000, 04:40 PM
i keep getting an error here in the glu.h file.

const wchar_t* APIENTRY gluErrorUnicodeStringEXT (
GLenum errCode);

Codewarrior 4 has a problem at the first line saying a ; is expected. I dont think this is normally supposed to happen, so is there a fix or something i need to do different out there?

Thanks

Tone
11-06-2000, 12:12 PM
Perhaps this is a stupid question, but are you including windows.h before you include glu.h. If not, then this is most likely the source of your problem. Without including windows.h, the compiler won't know what APIENTRY is when it sees it in glu.h and will generate an error. Hope this helps.

Tone

humberto
11-06-2000, 02:51 PM
Hi CHEF,

try this:

const wchar_t* APIENTRY gluErrorUnicodeStringEXT (GLenum errCode);

Tarquin13
07-15-2001, 07:49 AM
I have the same error, I include windows.h above gl.h and glu.h and humberto's line doesn't seem to work... any other fixes?

SminkyMinkyPinky
07-15-2001, 09:28 AM
perhaps wchar_t isn't defined?

if this is a Windows project (I can't help if it's Linux or Mac), do you have _UNICODE defined somewhere? I believe you'll need to make sure it's defined before windows.h is included...

but don't quote me, I'm stuck back in the 60's with ASCII http://www.opengl.org/discussion_boards/ubb/wink.gif

If you're in windows using VC, then the easiest thing would be to go to Project/Settings/CC++/General/Preprocessor definitions and put the definition in there.


HTH