PDA

View Full Version : IJL in VC,link erro..



Suvcon
01-27-2002, 12:31 AM
why?
Miss some setting in VC6 ?

http://www.opengl.org/discussion_boards/ubb/frown.gif

--------------------Configuration: jpeg - Win32 Debug--------------------
Compiling...
main.cpp
Linking...
main.obj : error LNK2001: unresolved external symbol "void __cdecl
jpeg_destroy_compress(struct jpeg_compress_struct *)"
(?jpeg_destroy_compress@@YAXPAUjpeg_compress_struc t@@@Z)
main.obj : error LNK2001: unresolved external symbol "void __cdecl
jpeg_finish_compress(struct jpeg_compress_struct *)"
(?jpeg_finish_compress@@YAXPAUjpeg_compress_struct @@@Z)
main.obj : error LNK2001: unresolved external symbol "unsigned int __cdecl
jpeg_write_scanlines(struct jpeg_compress_struct *,unsigned char *
*,unsigned int)"
(?jpeg_write_scanlines@@YAIPAUjpeg_compress_struct @@PAPAEI@Z)
main.obj : error LNK2001: unresolved external symbol "void __cdecl
jpeg_start_compress(struct jpeg_compress_struct *,unsigned char)"
(?jpeg_start_compress@@YAXPAUjpeg_compress_struct@ @E@Z)
main.obj : error LNK2001: unresolved external symbol "void __cdecl
jpeg_set_quality(struct jpeg_compress_struct *,int,unsigned char)"
(?jpeg_set_quality@@YAXPAUjpeg_compress_struct@@HE @Z)
main.obj : error LNK2001: unresolved external symbol "void __cdecl
jpeg_set_defaults(struct jpeg_compress_struct *)"
(?jpeg_set_defaults@@YAXPAUjpeg_compress_struct@@@ Z)
main.obj : error LNK2001: unresolved external symbol "void __cdecl
jpeg_stdio_dest(struct jpeg_compress_struct *,struct _iobuf *)"
(?jpeg_stdio_dest@@YAXPAUjpeg_compress_struct@@PAU _iobuf@@@Z)
main.obj : error LNK2001: unresolved external symbol "void __cdecl
jpeg_CreateCompress(struct jpeg_compress_struct *,int,unsigned int)"
(?jpeg_CreateCompress@@YAXPAUjpeg_compress_struct@ @HI@Z)
main.obj : error LNK2001: unresolved external symbol "struct jpeg_error_mgr
* __cdecl jpeg_std_error(struct jpeg_error_mgr *)"
(?jpeg_std_error@@YAPAUjpeg_error_mgr@@PAU1@@Z)
Debug/jpeg.exe : fatal error LNK1120: 9 unresolved externals
Error executing link.exe.

jpeg.exe - 10 error(s), 0 warning(s)

01-27-2002, 08:20 PM
Looks like your missing a library (.lib). However I couldn't tell off hand which one

Suvcon
01-27-2002, 08:58 PM
I compiler the files into a lib:libjpeg.lib

then i copy to the direction of "lib"

then i copy the header file jpeglib.h and other into direction of "include\jpeg"

i include the header jpeglib.h in my project,and add the lib in the setting dialogue box,i mean the vc6.

but i get erro.

http://www.opengl.org/discussion_boards/ubb/frown.gif