PDA

View Full Version : Cracks!



PeterK
07-21-2000, 01:20 PM
When I run my program on a machine with an 4MB ATI Rage graphics card everything renders nicely (except when the scene becomes too complex and then noisome and foul cracks appear on each edge of my polygonalized surfaces).

I had thought that the cracks would disappear on a machine with a (bigger and) better video card -I was wrong. I tried out my scene on a computer with a 64MB Elsa gloria II and it displayed the same cracks at all resolutions and complexities! http://www.opengl.org/discussion_boards/ubb/confused.gif

I can actually see through the edges of my polygonalized surfaces and see objects through the cracks.

I have JPEGs of cracked and uncracked surfaces if anybody wants to see them.

I'm betting that I have some settings wrong. Does anyone have any ideas?


[This message has been edited by PeterK (edited 07-21-2000).]

AndersO
07-21-2000, 01:59 PM
No.. I have cracks too on my geforce 256.. Infact all graphics card I've used have had cracks.

At T-junctions where the polygon above the T doesn't share the vertex "in the middle" the cracks are almost certain to appear.

But even on edges where vertex are shared I have cracks.. I would think it's the way the driver handles the edges, "scaning"/rasterizing from vertex A to B does not have the same pixels drawn when the edge is done the B to A way..

So I dont think there is some specific setting for this in OpenGL to fiddle with.

The only way I know is to have overlapping.. Or dont care about it.

http://www.opengl.org/discussion_boards/ubb/frown.gif

cheers

PeterK
07-21-2000, 03:31 PM
This is bad news... http://www.opengl.org/discussion_boards/ubb/eek.gif

My scenes look really bad with all the cracks -even stock objects like gluCylinder have cracks that make them look really bad when rendered as solids.

When the surfaces are small (and their composite polygons are smaller) the cracks dominate the rendering, making the surfaces look moldy (and quite unattractive).

The next image was rendered using the 64MB Elsa GloriaII:

http://members.tripod.com/peterkennedy/03f26960.jpg

This one using a 4MB ATI Rage video card:

http://members.tripod.com/peterkennedy/05007a90.jpg

What can be done to fix this? I hope that overlapping is not the only option.

[This message has been edited by PeterK (edited 07-21-2000).]

ngill
07-21-2000, 10:24 PM
do you have a link? I don't think the problem is THAT bad... when I use glutSolidSphere I can't see ANY cracks!!!

AndersO
07-22-2000, 12:40 AM
Oh... Hmm.. I dont have that severe cracks like on your elsa II jpeg.. I dont see any cracks on the ati rage image.. Maybe its the loss compression.

Usually the cracks I have are a couple of pixels..

I asume the elsa II is a geforce of some kind, so I would recomend downloading new drivers from nvidia.

Are there cracks in other OpenGL programs than yours?.. I.e quake?

ayea, I had to copy the link location and open a new browser window in order to get to the image. Weird, maybe its a forum thing.

cheers

[This message has been edited by AndersO (edited 07-22-2000).]

Cruxis
07-22-2000, 02:20 AM
By the looks of it I would say that you are not disabling stippling and that is on for the cracked image. Try putting this before
your drawing code and see if it makes a difference.

glPolygonMode(GL_FRONT_AND_BACK,GL_FILL);
glDisable(GL_LINE_STIPPLE);
glDisable(GL_POLYGON_STIPPLE);

I hope that was to some help.
Anyway, Good luck.

Marcus "Cruxis" Lenngren - Nopp



[This message has been edited by Cruxis (edited 07-22-2000).]

PeterK
07-22-2000, 08:19 AM
Here's a link with the two images:

http://members.tripod.com/peterkennedy/index.htm

AndersO, Good point -I don't see these cracks with other OpenGL programs.

Cruxis, I'm going to give your suggestion a try -I will be very happy to fix this!


[This message has been edited by PeterK (edited 07-22-2000).]

Cruxis
07-22-2000, 08:24 AM
Okej, Lets hope for the best.
The cracks doesnt look like z tearing.
But to be on the safe side, put znear
to at least 1.0f just to see.

Now I am all empty on suggestions http://www.opengl.org/discussion_boards/ubb/smile.gif.

/Marcus "Cruxis" Lenngren - Nopp

PeterK
07-22-2000, 09:10 AM
Cruxis, I tried disabling the polygon and line stippling but it had no effect.

Your comment about z-tearing is interesting. When I programmed the frustum, I chose rather high values for the near face and far face (z = 1000 and z = 1500 respectively!) because it produced a reasonable viewing volume (and perspective) for the objects I had created.

I am suspicious that these znear and zfar values are causing problems. What do you think?

Relic
07-22-2000, 09:47 AM
Hi Peter,

the image with the artifacts you name cracks looks like you have some type of blending and polygon antialiasing enabled.
If that's the case the ELSA Gloria II does the right thing and the ATI the wrong, which is no antialiasing.

If I'm correct, you'll have to enable the blend mode with alpha saturation and sort polgons from front to back to get proper polygon antialiasing effect (see Redbook).
Beware, this might be slooow.

07-22-2000, 09:58 AM
Hi,

I was also having cracks in my OpenGL program (in complex one) till I discovered that the problem where the drivers. I have a TNT2 card and first I had the drivers of the manufacturer of the card, Leadtek. After I installed the new drivers from NVIDIA and everything was ok!

Miguel

AndersO
07-22-2000, 10:27 AM
If the problem still exists after updating the drivers, post some small code example wich have the cracks.

PeterK
07-22-2000, 10:47 AM
http://www.opengl.org/discussion_boards/ubb/biggrin.gif I turned off all blending and anti-aliasing and the moldy rendering disappeared.

Thanks Relic for the answer (and everyone else for the ideas).

I am really happy! Handshakes all 'round!