PDA

View Full Version : I want to use OpenGL 1.2



Paitum
11-10-2000, 06:54 AM
I am going through the "OpenGL Programming Guide (Third Edition)" and I tried to do the following line:

glGetFloatv(GL_SMOOTH_POINT_SIZE_RANGE, size);

but the compiler said it didn't know what GL_SMOOTH_POINT_SIZE_RANGE was. So I looked in the gl.h file and couldn't find this constant anywhere. I noticed that my gl.h file says:

#define GL_VERSION_1_1 1

So does that mean I'm compiling using version 1.1? And if so, where can I get 1.2 headers and libraries for windows?

11-10-2000, 09:22 AM
Originally posted by Paitum:

So does that mean I'm compiling using version 1.1? And if so, where can I get 1.2 headers and libraries for windows?

Ask Bill!
M$ already has 1.2

Paitum
11-10-2000, 10:53 AM
Huh- I've already done some searching at Microsoft, SGI, OPENGL, and even nVidia for the libraries and headers. But no success.

11-10-2000, 02:49 PM
They have got it from SGI but refuses to release it. You can use the extensions instead.