PDA

View Full Version : Can you give me some benchmarks on my engine?



Bruno
01-11-2001, 09:52 AM
You can get it from:

brunomtc.no.sapo.pt/fy.zip

On the console, type "FPS ON"
Press SPACE to open the doors

thanks for any feedback

Bruno

Teofuzz
01-11-2001, 12:13 PM
missing msvcrtd.dll ...
Sorry!
Fuzz

01-11-2001, 02:29 PM
Tried executing your engine executable and I got to the dialog window. I picked windowed, 800x600, 16bit, and turned off mirrors, etc.

It gave me a page fault, and forced me to reboot in order to reset the card, or some driver. http://www.opengl.org/discussion_boards/ubb/frown.gif

I'm running an AMD 650 with a Voodoo 3 2000 PCI.

element
01-11-2001, 03:29 PM
I got an error that says: "The OPENIL-D.DLL file is linked to missing export MSVCRTD.DLL:_chkesp.

I found Msvcrtd.dll in c:\windows\system and copied it to the same directory as this program but still same error. Running Win98 and DirectX8 with all the latest updates here.

Zadkiel
01-11-2001, 03:31 PM
The same post in two forums, here and NeHe sites. I'd complain if I hadn't just done the same.

Bruno
01-11-2001, 03:57 PM
Well, i posted in more than one forum, because i know that there are people that came here, and don't go to Nehe's, that was the reason..,
I don't know what is the problem, page faults?
I can't run it in Release mode, maybe that is something to do with you guys being unable to run on your machines.., well, i placed the dll file in http://brunomtc.no.sapo.pt/MSVCRTD.zip , so that people that don't have VC installed , and want to see the engine may.

thanks

Bruno

Elixer
01-11-2001, 07:22 PM
I also got a crash. I get "the instruction 0x004475fa referenced memory at 0xccccccc. The memory could not be "written""

This is with Win2k + geforce AMD system.

HoHo
01-14-2001, 12:06 AM
Originally posted by Elixer:
I also got a crash. I get "the instruction 0x004475fa referenced memory at 0xccccccc. The memory could not be "written""

This is with Win2k + geforce AMD system.



I think I had similar problem with some debug dlls (somethingD.DLL) in visual c++ 6.0. I solved it with replacing them with the older ones from vc 5.0. I dont know if it works, but try it http://www.opengl.org/discussion_boards/ubb/smile.gif

Humus
01-14-2001, 01:54 PM
It crashed on me too.

01-14-2001, 04:56 PM
I tried win2k and winME
on a
pIII 600
geforce256 DDR

same error on both os's

01-14-2001, 10:05 PM
Sounds like the program is accessing memory that hasn't been allocated...like going past the end of an array, or somesuch. Perhaps you left out some checks to ensure the program exits gracefully when something like that happens? http://www.opengl.org/discussion_boards/ubb/smile.gif

Bruno
01-14-2001, 11:50 PM
Thanks for the suggestion...
But how can it allocate memory on some systems, and being unable to do it in another systems ?

Bruno

Deiussum
01-15-2001, 06:07 AM
I got a crash too, but I'm on my work computer, which doesn't have the greatest OpenGL support. Are you using extensions at all? If you are using extensions and not properly checking for them, I can see why it could crash on some machines and not others.

Bruno
01-15-2001, 12:12 PM
Yep.., i'm using extensions, but i'm checking if they exist.., if they don't exist i don't use them, i have no clue why it's crashing on some systems and not on others.

Bruno