PDA

View Full Version : Video card problems..ATI..Voodoo...black window



Tanuki
06-09-2000, 08:37 AM
I believe that I posted ithis on the wrong BB before ..sorry


Hi,
I have been developing an OpenGL app and have noticed that certain video cards seem to display elements of an OpenGL scene as black sillouettes (sp). I believe this is due to their lack of OpenGL compliance due to the drivers... but I'm not certain.

When I run my app on an ATI PRO LT equipped PC, all my polygons appear as black outlines, although raster fonts and lines appear as normal.

On an ATI Mobility equipped PC, OpenGL graphics are blacked out but this even includes the lines, but excludes raster fonts.

On a Voodoo3 equipped PC, my computer dies on OpenGL set up (this machine has had the GLQuake dlls pasted over its windows default OpenGL dlls), the icons on the desktop and toolbar all turn white and dialog pop ups leave dont display correctly.

I have only had this trouble running my app on these particular cards. Both the ATI ones are new cards with initial release drivers, these drivers do not have good OpenGL support at present. A machine kitted out with exactly the same hardware and software as the Voodoo3 machine, minus the GLQuake files, also runs fine.

I can eliminate the problems with these cards by either changing the windows colour depth to 24/32bit (rather than 16bit), or by turning hardware acceleration off.

Can anyone help me get my app to work with these card in 16bit colour depth, or is it just a side effect of the card's attempts at hardware acceleration (thus requiring me to wait for better drivers)?