View Full Version : Mandrake 7.2, Voodoo 5500, Quake 3

04-11-2001, 09:49 PM
I have Mandrake 7.2 and a voodoo 5500 video card. Whenever I run Quake 3 or
any program requiring MESA or GLIDE I get errors. When I run Quake 3 I get
the follow error:

...loading libGL.so: QGL_Init: Can't load libGL.so from /etc/ld.so.conf or
current dir: libglide2x.so: cannot open shared object file: No such file or
...loading libMesaVoodooGL.so: QGL_Init: Can't load libMesaVoodooGL.so from
/etc/ld.so.conf or current dir: libglide2x.so: cannot open shared object
file: No such file or directory
----- CL_Shutdown -----
RE_Shutdown( 1 )
----- CL_Shutdown -----
Error: GLimp_Init() - could not load OpenGL subsystem

The file ld.so.conf has the following entry in it : /usr/x11R6/lib. That
directory has both the libGL.so and LibMesaVoodooGL.so drivers in it. My
system has the MESA library 3.3-14mdk installed and the MESA-common version
3.4.1-2mdk installed, as well Glide_V5 cvs-1mdk which should allow me to use
the DRI architecture. Also, there is Xfree86-glide-module 4.0.1-28mdk

Please help as no one else appears to want to. I have contacted Mandrake and
got the standard Linux distro customer (lack of) support response:

"Thank you for using MandrakeSoft Professional Services technical support.
Unfortunately your question dealing with glide or mesa setup isn't
currently included in our list of free support provided."

I've also searched every forum I could find in the chance that someone has
had this problem but have been unable to find anything pertinent.

Any help would be most appreciated, thanks in advance.

04-24-2001, 07:42 PM
This may work but I am not sure. I had to do this sort of thing to get a half-life server working in Mandrake 7.0.

Make sure that the path to the libGL.so and libMesaVoodooGL.so files are in the "ld.so.conf" file and then run "ldconfig" configuration program. And then try it again running the game again.