View Full Version : I know, you've probably heard it before - could not load OpenGL subsystem

06-15-2002, 05:51 AM
Basically whenever I try to play any games which need OpenGL, I end up with the console telling me the line the most of you have probably seen before "GLW_StartOpenGL() - could not load OpenGL subsystem" This happens when I try to play Quake 3 Arena, Star Trek Voyager : Elite Forces, and also Star Wars Jedi Knight 2 : Jedi Outcast. I have Windows 98 first edition, NVIDIA RIVA TNT2 Model 64/ Model 64 Pro, AMD Athlon 600Mhz, 64MB Memory.
I tired what it said in the troubleshooting guide for Jedi Outcast, checked my graphics card was compatible, it is, I downloaded the latest drivers, still no help, I asked a friend and he said reinstall the drivers for the graphics card, I tried that and still to no avail. I hope you guys have anything which may help me, but at the moment, all I can think of is formatting the hard drive and trying again.
Also below is the whole console I receive when I try to load up the game, if it helps anyone who can understand all of that.

JK2: v1.03 win-x86 May 3 2002
Initialising zone memory .....
----- FS_Startup -----
Current search path:
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets2.pk3 (289 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets1.pk3 (8011 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets0.pk3 (6674 files)
C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData/base

14974 files in pk3 files
execing default.cfg
couldn't exec jk2config.cfg
couldn't exec autoexec.cfg
...detecting CPU, found AMD w/ 3DNow!

------- Input Initialization -------
Skipping check for DirectInput
Joystick is not active.
----- Client Initialization -----
----- Initializing Renderer ----
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Working directory: C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\SYSTEM\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using desktop display depth of 16
...calling CDS: ok
...registered window class
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...23 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
----- CL_Shutdown -----
RE_Shutdown( 1 )
GLW_StartOpenGL() - could not load OpenGL subsystem

Thanks in advance

06-15-2002, 09:52 AM
man i got the same problem with the open gl subsytem thingy.........i have a tnt2 and a p4 and im runnin windows XP.......


06-15-2002, 12:09 PM
yeah man im on a p3 800 runnin a tnt 2 card on xp and i got the same stuff, but only since i wiped my drive, it worked fine when i was runnin ME WE NEED HELP

06-16-2002, 10:10 AM
I have the same prob too but on w2k with the same vid card.. I cant play any games that require openGL.. in XP the games run fine..

I have eliminated out vidcard drivers because those worked B4.. DirectX is 8.1....
please help http://www.opengl.org/discussion_boards/ubb/wink.gif

06-16-2002, 06:17 PM
man i have the exact problem but i might figure it out if i can just have someone tell me where the files go?? cuz i have SOFII multi test and i neeed OPENGL bad!!!

06-18-2002, 12:13 AM
are you guys going to www.nvidia.com (http://www.nvidia.com) and downloading the detonator drivers?

if not - do so

06-18-2002, 06:57 AM
I have the some thing on Star wars Jedi Knight 2


Email me if you find out...

[This message has been edited by PDBJesusFreak (edited 06-18-2002).]

06-18-2002, 08:05 AM
I've tried the latest detonator drivers already, still no good.

06-23-2002, 09:48 AM
Ive done everthing they say and I still have problems...

heck... I have a recommened Card... With chip set... same driver and driver version they use and im still getting the same error... Ive gone to there webpage looked at all the help... even submetted to Yoda 4 times already and 24 hours later still no reply... Ill help if they replay but doesnt look like they even know whats going on...

06-23-2002, 09:16 PM
K same problem...hey vo...ok you said it worked on XP right? Well i'm using XP Pro and it's still says the subsystem is not able to initiate....i'm wondering if my drives are updated but i'm new to this and i really dunno how to find out...

06-25-2002, 03:43 PM
I used to be able to play jedi outcast in win 98. I did a fresh install of xp pro and bam- the typical open gl error message you all mentioned. I also get the error in soldier of fortune 2. I think we will find in the future that a patch will be developed to fix this problem. Either a game patch or a driver upgrade that will correct it. Too many people are experiencing this problem for it to be a minor issue. I have a dell system with the latest nvidia drivers and have tried doing everything possible and still no dice. These game mfg's need to get their act together. These are name brand vid cards we're dealing with here, not foreign knock offs. If they can't design a game to run on a generic system with top name components then these games should cost ten bucks not fifty. These Rip off game companies suck!

06-26-2002, 08:10 AM
But you see the thing is, I haven't changed anything, my games were working absolutley fine, but this happened a couple of months ago, I must have done something, maybe deleted something by accident, that's why I am thinking of formatting my hard drive, and trying to reinstall all the drivers and games, but I don't wanna do that if there is something much easier to do which will solve the problem. All I ever see is a lot of problems, but no one able to ever deliver answers, I think everyone can see that in this post...

06-27-2002, 03:32 AM
thats it i m so fuc... angry on all that bunch of stupid nVIDIA people and OpenGL people they have produed a software that isn t working with hardware they are ohhhh gggg **** it all i ve got 3 games MOHAA, SOF2 and Q3 and all of them are not!!! working on this **** !!!! and even if i want to solve this problem i couldn t because i couldn t even contact them it is **** and i don t want to talk about it !!!!

desperadoooo ;]

07-02-2002, 10:44 PM
OK guys just thought id pop in with a Note or to
I have a duel Boot PC
98SE and 2000 pro
Now in 98 everything works fine but in 2k pro i have that error.
Ive noticed it that this problem seems to happen with the TNT 2 cards
I am looking for away around this at the moment if anyone has it please feel free to email me if not email me to see if i have found a way that way i can keep intouch with those that are eager

07-03-2002, 12:08 PM
It seems everyone is having this problem, me to! so why dosen't any one from OPENGL answer our question? I have Windows XP with a g-force 2, and Medal of Honor AA and Star Wars Jedi Knight 2 doesn't work!!!
PLEASE HELP!!!!!!!!!!!!!

07-04-2002, 12:27 PM
yes me as well but its funny i used to play quake 3 no problems ,but since this started up i have not tried it something is screwed somewhere what is all this pixel format rubbish

07-05-2002, 08:50 PM
i have winME (the worst of them alll i know)
with a ATI Radeon 7500 i sued to have mohaa quake III and counter-strike installed and like some of you guys soemthing happened awhile ago when all my games stopped working cause of opengl (i could have done something but i dont think so) i was actauly playing counter-strike in the 3d mode. does anyone know a good link to d/l opengl??? all the freakin game companys tell me glsetup.com but where at glsetup.com!!!!?????!!!! and where is opengl admin people this is a place for help so help us!!!!!!!

07-06-2002, 09:06 PM
i have a trident/opengl video card and run windows 2000 on a laptop and have the same error generated when I downloaded mohaa

07-08-2002, 05:42 AM
ok I know now the solution. There are two different kind of reasons that are cousing this problem:
1. You've got Windows XP or 2k this is the problem of Microsoft programmers so we have to wait till they ll fix up and will make a patch to it. So to get out of this sh*t you have to install a secound OS (for example Windows 98) and, like I did, play the game on it.
2. You have to remove the line DVA=0 from your win.ini file in WINDOWS folder by putting at the beginning ";" so it will be something like this: ;DVA=0 .

Ohh it can be something else but I ve found this two solutions. Mail me if you have any probs with this on brox@poczta.fm

07-08-2002, 08:29 AM
Thanks br0x. Finally my games worked, that line ";DVA=0", thanks for your help. I really do appreciate it.

[This message has been edited by gigabz666 (edited 07-08-2002).]

07-09-2002, 11:07 AM
that DVA=0 line aint in my win.ini file HELP!? please http://www.opengl.org/discussion_boards/ubb/smile.gif

07-11-2002, 01:05 AM
I thought, I am the only one with this problem,but oviously... i tried to play Mohaa ,but OpenGl says "can't open a subsystem".I have windows XP pro on my pc,but I didn't find that line "DVA" in my win.ini too.So if there is anybody out there,who knows the solution,Pleeeeeeeeeeeeease help!

07-11-2002, 02:25 AM
I use Win XP, and GeForce 2 with glases.
I see this **** everytime that im trying to play quake III in stereo mode. So if u had mada some chabges in our cfg file...that is the problem (maybe http://www.opengl.org/discussion_boards/ubb/smile.gif. Open your Quake III arena folder? then enter to Baseq3 or something like that, an then open file baseq3.cfg with notepad. Try to find this "r_stereo" it would look like r_stereo "1" change 1 to 0...save changes, if still doesnt work then forget about it http://www.opengl.org/discussion_boards/ubb/smile.gif
good luck

07-12-2002, 07:29 AM
Wow a lot of ppl are having this problem. I have 2 comps, one with a kind of old trident display port on it and one with an ATI vid card on it. They're both on xp pro and I can' find the DVA line in my win.ini file. Also at the glsetup.com I found where you're supposed to download the files but the files aren't there, only the links.

07-14-2002, 11:49 AM
we are all in the same boat it seem that it happens to most os cards and games from the old to the new so where are the brains that can fix this come on gl we need a cure if it was for 1 game then fine but its not its meny games with meny cards and os but the problem is the same for them all.
ps i have tryed 3 days and nights of drivers, wini configs ,open gl fixes
i run xp voodoo3000 256 ram amd900 not the best by far but surely enough to play a game(medal of honor}

07-14-2002, 07:10 PM
I have win2k, so the DVA=0 didn't work for me, but overwriting my ogl files in system32 with the files found here: http://download.microsoft.com/download/win95upg/info/1/W95/EN-US/Opengl95.exe fixed the problem for me.

07-15-2002, 07:32 AM
thanks for your reply but no joy i just get this
--- Common Initialization ---
Medal of Honor Allied Assault 1.11 win-x86 Mar 5 2002
----- FS_Startup -----
Current search path:
D:\New Folder/main
D:\New Folder\main\Pak5.pk3 (259 files)
D:\New Folder\main\Pak4.pk3 (593 files)
D:\New Folder\main\Pak3.pk3 (669 files)
D:\New Folder\main\Pak2.pk3 (4722 files)
D:\New Folder\main\Pak1.pk3 (772 files)
D:\New Folder\main\Pak0.pk3 (11175 files)

18190 files in pk3 files
execing default.cfg
execing menu.cfg
execing newconfig.cfg
Config: unnamedsoldier.cfg
couldn't exec configs/unnamedsoldier.cfg
execing safemode.cfg
couldn't exec localized.cfg
execing autoexec.cfg
Unknown command "fov"
couldn't exec custom.cfg
...detecting CPU, found AMD w/ 3DNow!

------- Input Initialization -------
Initializing DirectInput...
Couldn't set DI coop level
Falling back to Win32 mouse support...
------- Input Initialization Complete ------- 88
You are now setup for easy mode.
----- Client Initialization -----
Called FadeSound with: 0.000000
----- Initializing Renderer ----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): failed
...shutting down QGL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\3dfxvgl.dll' ): failed
...shutting down QGL
GLW_StartOpenGL() - could not load OpenGL subsystem

i am going to have a look for the drivers that are in there if not in my pc then i will look on the net if i find a cure i will post it

07-16-2002, 06:02 AM
UHHH!!!! What the ****? It is so so much annoying, everybody got the same problem but there is no answer to fiz the problem. This is NO FAIR! I got the same problem, here how it starts;

months b4 I downloaded a game(cant remember the name, maybe SoF??) there was saying OpenGL is needed, and I downloaded the file from the net, it takes so much time but it was worth cuz the game worked, I formatted my PC and now I wanna play Medal of Honar AA, I downloaded it and when I wanted to start there came a long console and at the last says:
GLW_StartOpenGL() - could not load OpenGL subsystem
I tried to download the files from glsetup.com but there's only links, no files, I tried to find those from the net, I found sth like these: http://www.glsetup.com/cgi-shl/mirror.cgi ==> when u go automoticly the download will start, but this is a 88 MB file, it takes so much time, I couldnt download yet, and I dont think I will be able to...
also: http://download.microsoft.com/download/win95upg/info/1/W95/EN-US/Opengl95.exe
this couldnt work I ran the exe file there came dll files and I overwrite the files to system dir but it couldn work, I dont know maybe this could work for you.
I opened win.ini and I couldn find any DVA=0 line out there, should I write a line myself?
please please someone out there write the answer, isnt there anybody from opengl.org reading these messages, everybody having the same damn problem, but there is NO fix, they may put the glsetup.exe to the glsetup.com site, but there are NO files there are ONLY links, I wanted to write it again, please answer!! please! HELP!!!!

07-16-2002, 08:29 AM
Originally posted by PDBJesusFreak:
I have the some thing on Star wars Jedi Knight 2


Email me if you find out...

[This message has been edited by PDBJesusFreak (edited 06-18-2002).]

07-16-2002, 10:03 AM
i have sent open gl an e/mail to see what the come up with i have asked them to have a look at this forum i will post the reply if i get one

07-16-2002, 01:26 PM
ignore my post, that actually didn't work :[

07-16-2002, 06:10 PM
Originally posted by FP:
ignore my post, that actually didn't work :[

On the subject I have discovered two POSSIBLE fixes for XP/W2K users

This comes from a Q3 game forum where people were getting the Opengl Subsystem error

Solution for those workin with Win XP:
Go into the WINDOWS\SYSTEM32\DLLCACHE directory and delete OPENGL32.DLL
Go into the WINDOWS\SYSTEM32 directory and rename OPENGL32.DLL to OPENGL32.OLD
Windows will pop up a dialog saying a protected system file has been modified and to insert your WinXP cdrom. Click Cancel and then Yes.
Copy the file WINDOWS\APPPATCH\ACXTRNAL.DLL into your WINDOWS\SYSTEM32 directory and rename it OPENGL32.DLL
Finally reboot your machine.

This works with XP for sure. There shoudh be a similar method for win2k boxes, but am not sure.

And this fix

A guy in the opengl.org forums who ran W2K says he fixed his issue by downloading this file, then renaming the glu32.dll and opengl32.dll in his windows, system32 directory and extracting ONLY those two files using winzip from the exe into the system32 directory.

There may be more steps invovled, as in my experience, windows won't just let you overwrite system dll's, but maybe if you have not run any opengl apps yes....

I suggest a reboot after doing it. What is there, is a opengl 1.1 update for windows 95 users, and its older and smaller than the files I have on my system. My glu32 (114K) claims to be a 5.1.2600.0 (xpclient.010817-1148)
and my opengl32.dll (669K)originally claims to be 5.1.2600.0 (xpclient.010817-1148) [under file version, not product version]

Anyway, someone willing to test this that has the OPENGL 1.1.0 issue under W2K, write back and let people know if it helped, made things worse, or whatever.....

I am not sure what the deal is exactly but in all cases it seems neverWinter nights is misreporting the opengl version as 1.1.0 [even the DVA=0 issue under win 9x] and that is why the subsystem fails to load. In NWN you just fail to meet the requirements which are for oprngl 1.2+ but... It seems what happens is the hardware vendors oepngl icd cannot be loaded and your stuck with just ms's opengl32.dll which is not complete for a hardware vieo card.

One can only assume w2k/XP uses dllcache for libs, and that the vendor ICD is copied there before you got the up to date drivers, and was not replaced/refreshed correctly with the new dll ? Not sure exactly but if it works, cheers anyway... Note you may need to set explorer to stop hiding system files to see the directory, it is apparently compressed though.......

07-16-2002, 09:59 PM
Originally posted by wallsie:
thanks for your reply but no joy i just get this
--- Common Initialization ---
Medal of Honor Allied Assault 1.11 win-x86 Mar 5 2002
----- FS_Startup -----
Current search path:
D:\New Folder/main
D:\New Folder\main\Pak5.pk3 (259 files)
D:\New Folder\main\Pak4.pk3 (593 files)
D:\New Folder\main\Pak3.pk3 (669 files)
D:\New Folder\main\Pak2.pk3 (4722 files)
D:\New Folder\main\Pak1.pk3 (772 files)
D:\New Folder\main\Pak0.pk3 (11175 files)

07-17-2002, 11:51 AM
i have the same problem and i tried the thing WhiteChedda suggested, but i dont have a DLLCACHE and i cant rename the ACXTRNL.dll file because whenever i delete opengl32.dll and try to rename the ACXTRNL.ddl opengl.dll magically appears at the bottom and so i cant rename ACXTRNL.dll

It's pissing the hell out of me, i have 2 comps running XP and on one comp the games work fine, but on the other i keep getting that same bloody error. URG!!! #%&#^$&#@%^@&%@&%#$&#^*#^%^$*^

All i wanna do is play my games.... http://www.opengl.org/discussion_boards/ubb/frown.gif, so will some person from Opengl actually present us with the bloody solution!!!!

07-18-2002, 05:14 AM
I did find some answers on the Activision website. I hope these will help. I'm going to try these this evening. Greetz, Datamind

I receive the error: Could not load OpenGL subsystem.

Check to make sure you have a supported 3D video card to play the game. Return to Castle Wolfenstein requires that you have one of the supported 3D cards to play the game. Your card must have 100% OpenGL support and at least 16 MB of memory. A list of the supported chipset is listed in the minimum system requirements.

Make sure you have the latest video and sound card drivers from the manufacturers' websites.

If you have a motherboard with an onboard video card you need to disable it in the system BIOS. Refer to your motherboard manual and/or contact your motherboard manufacturer on how to do this.

If you are using a video card which supports dual monitors, the secondary monitor must be disabled for OpenGL to initialize correctly.

Make sure the 3D hardware acceleration is turned all the way up.
1) Right-click on the My Computer icon on the desktop and select Properties.
2) Select the Performance tab and click the Graphics button.
3) Make sure the acceleration slider is set to Full.

For Windows XP:
1) Click on the Start button > Settings > Control Panel.
2) Double-click the Display icon.
3) Click the Settings tab.
4) Click the Advanced button.
5) Click the Troubleshoot tab.
6) Make sure the acceleration slider is set to Full.

Set your desktop settings to 640 by 480 and High Color (16 bit).

All background applications must be shutdown prior to running the game.

If after trying the above solutions the game still does not work, check the following:
1) Click on the Start button > Run and in the run box type "Sysedit" without the quotes and click the OK button.
2) When Sysedit comes up you should see a bunch of cascaded windows, select the window that says Win.ini above it.
3) The Win.ini window should come to the foreground, scroll through the list of items until you come to [DrawDib].
4) Look for a line under [DrawDib] that says DVA=0 and remove it.
5) Click File, then Save and close the Sysedit program.
6) Try the game at this point.

If you do not see the DVA=0 line under the [DrawDib] section, then this is not the cause of your problem. DVA stands for Direct Video Access, and is commonly set to 0 to fix issues with older games or video problems with old software. Unfortunately it causes Return to Castle Wolfenstein to not recognize OpenGL support on your system as well. The only way to fix this is to remove that line. This should not affect anything on your system.

Set your virtual memory to a fixed size.
1) Right-click on My Computer and select Properties.
2) Click the Advanced button, click on Performance settings.
3) Click the Advanced tab, click the Change button.
4) Set the Virtual Memory to a minimum and maximum size of 600MB.
5) Confirm your selections until at the desktop - you may need to reboot.

NOTE: These steps are specific to Windows XP, Windows NT and 2000 may differ slightly.

This will occur when insufficient Virtual Memory is available for the game. For the best performance and stability under Windows NT, 2000 and XP you should aim for having at least 600MB of virtual memory available.

Turn off GL Extensions in the game by changing the configuration file.
1) Click the Start button > Programs > Accessories > Wordpad.
2) Open the wolfconfig.cfg file which is located in the Return to Castle Wolfenstein\Main directory on your machine.
3) Locate the line reading:

seta r_allowExtensions "1"

4) Change the 1 to a 0.
5) Click File > Save.

If you are not using a 3Dfx video card, disable the WickedGL support in the game.
1) Click the Start button > Programs > Accessories > Wordpad.
2) Open the WOLFCONFIG.CFG file located in the C:\...\Return to Castle Wolfenstein\Main directory.
3) Located a line reading:

seta r_glIgnoreWicked3D "0"

4) Change the "0" to a "1".
5) Save the file.

It is possible the game is having issues generating the configuration file on it's first run. Try downloading and installing the wolfconfig.cfg file listed below to the game's \MAIN directory.

If you are using a 3Dfx video card try copying the custom 3dfx OpenGL files into the System directory.
1) Use My Computer to navigate to the Return to Castle Wolfenstein drive on your hard drive.
2) Double-click the GL folder
3) Click Edit then Select All.
4) Click Edit then Copy.
5) Again using My Computer, go to the C:\WINDOWS\SYSTEM* folder.
6) Click Edit, then paste. Do not overwrite any existing files.

* This directory name will change depending on what version of Windows you have.

Windows 95,98,ME: - C:\WINDOWS\SYSTEM
Windows 2000, NT: - C:\WINNT\SYSTEM32

Windows XP Users:
Please note that the default drivers that come with Windows XP are NOT OpenGL compatible. You will need to go to the video card or video chip manufacturer and obtain the latest Windows XP compatible drivers with OpenGL support. This is especially true for ATi and nVidia based video cards.

07-18-2002, 05:41 AM
The link too the Activision website:


07-20-2002, 02:34 PM
If any of you guys are using an old ATI graphics card and are running XP, loose ATI they dont support XP and opengl, all i had to do was get a new graphics card. ATI is bad at supporting older products. nVidia has been proven to work with XP and opengl, i got a GeForce and it works fine now.Just thought i would let you know.

07-21-2002, 11:57 PM
you got to go to video card maker for driver and to see if supports opengl
i got xp with gforce2 gts with uptodate
driver all games work great but had to update drivers first from nvidia alls
great now so check your video card manfacter
for driver (but make your card suport OPENGL
if not time for new card

07-22-2002, 12:22 PM
i have recevied a reply from opengl they just told me that there are no longer any drivers for the voodoo cards i was told that if the drivers that were given to me by opengl did not work then get the wallet out and get a new card. well the did not work but i can now use my tv out so not all was lost but i realy wanted to play mohor what do i do now mmmmm
ps heres the link i was given good luck http://www.voodoofiles.com/4979

07-24-2002, 09:27 AM
i got the same ****ty problem....but what is Glide? , it sats Glide is missing to ,and must i have a nvidi/ATI/voodo card? , or can i use the card that was in the pc when i bought it?

07-25-2002, 09:35 AM
Please help I got the same video card and I have tryed everything... A year now I just hate my p3 700 256mb ram, I am at the point were I will sell the thing for $4.99... Please help...Please help...I am desperate...