PDA

View Full Version : Finally my open gl worked!!!



07-17-2000, 11:07 AM
My open gl havenít worked for so long. I have looked in many forums and Ive come to a solution finally. This as follow is excerpt from many forums(no credit to me) and I think it will worked for most of you with open gl problems. Maybe its not the straightest line to the solution but Its better to exactly follow the list.
Well It worked for me. It seems this open gl problem occurs when you installing new drivers
(especially detonators). At least in my case.

My computer:

Windows 98
Celeron 300/450mhz
Asus p2b
Creative tnt2 ultra
128mb ram

Here it is:
- Run any uninstall from Add/Remove Programs for the drivers. These frequently are
not totally thorough but should be done anyway.

After you reboot, delete these files
In C:\Windows\System: nv*.*, bc*.*, bls*.*, 3dbg*.*
(the latter 3 only apply to Creative drivers)

In C:\Wwindows\Inf: drvdata.bin, drvidx.bin, 3dbg*.inf, nv*.inf

In C:\Inf\Other: 3dbg*.inf, nv*.inf

HKEY_LOCAL_MACHINE\SOFTWARE\Creative Tech\Blaster Control 3.0

HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Controls
Folder\Device\shellex\PropertySheetHandlers\Blaste r Control 3.0

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Controls
Folder\Device\shellex\PropertySheetHandlers\NVTwea k
(look under Controls Folder\Display as well as Device keys here for
Blaster Control or NVTweak keys)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run
- look for bcdetect or NVInitialize entries on the right side and
delete them but not the whole Run key. Also, check the RunOnce
key for the same entries.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\OpenGLdrivers
- delete the RIVATNT entry on the right side


After you have done this do a reinstall of windows(not format).

Then install the original drivers to your garaphiccard(not detonators)

Donít install any open GL drivers separately.

Then do as follow:


Click Start / Run.
Type "win.ini" (without quotes) and press OK.
Search for a line that says "DVA=0" (without quotes).
Add a semicolon ( http://www.opengl.org/discussion_boards/ubb/wink.gif before the DVA (The line should now look like this: ";DVA=0" (without quotes))
Save and close the file
If you find this causes more problems, just take out the semicolon.
Note that not everyone has this line, and if there is none you'll have to try another solution.
Try switching to AGP1X using your BIOS setup or AGP Wizard (more information here). This may help, but will reduce performance slightly.


Check your AGP aperture size in your BIOS Setup. Start at half of what your total system memory is and save it.


Thatís it
My open gl games work now.
Please give me a wink if it worked for you.

07-17-2000, 03:39 PM
Originally posted by Thelv:
My open gl havenít worked for so long. I have looked in many forums and Ive come to a solution finally. This as follow is excerpt from many forums(no credit to me) and I think it will worked for most of you with open gl problems. Maybe its not the straightest line to the solution but Its better to exactly follow the list.
Well It worked for me. It seems this open gl problem occurs when you installing new drivers
(especially detonators). At least in my case.

My computer:

Windows 98
Celeron 300/450mhz
Asus p2b
Creative tnt2 ultra
128mb ram

Here it is:
- Run any uninstall from Add/Remove Programs for the drivers. These frequently are
not totally thorough but should be done anyway.

After you reboot, delete these files
In C:\Windows\System: nv*.*, bc*.*, bls*.*, 3dbg*.*
(the latter 3 only apply to Creative drivers)

In C:\Wwindows\Inf: drvdata.bin, drvidx.bin, 3dbg*.inf, nv*.inf

In C:\Inf\Other: 3dbg*.inf, nv*.inf

HKEY_LOCAL_MACHINE\SOFTWARE\Creative Tech\Blaster Control 3.0

HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Controls
Folder\Device\shellex\PropertySheetHandlers\Blaste r Control 3.0

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Controls
Folder\Device\shellex\PropertySheetHandlers\NVTwea k
(look under Controls Folder\Display as well as Device keys here for
Blaster Control or NVTweak keys)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run
- look for bcdetect or NVInitialize entries on the right side and
delete them but not the whole Run key. Also, check the RunOnce
key for the same entries.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\OpenGLdrivers
- delete the RIVATNT entry on the right side


After you have done this do a reinstall of windows(not format).

Then install the original drivers to your garaphiccard(not detonators)

Donít install any open GL drivers separately.

Then do as follow:


Click Start / Run.
Type "win.ini" (without quotes) and press OK.
Search for a line that says "DVA=0" (without quotes).
Add a semicolon ( http://www.opengl.org/discussion_boards/ubb/wink.gif before the DVA (The line should now look like this: ";DVA=0" (without quotes))
Save and close the file
If you find this causes more problems, just take out the semicolon.
Note that not everyone has this line, and if there is none you'll have to try another solution.
Try switching to AGP1X using your BIOS setup or AGP Wizard (more information here). This may help, but will reduce performance slightly.


Check your AGP aperture size in your BIOS Setup. Start at half of what your total system memory is and save it.


Thatís it
My open gl games work now.
Please give me a wink if it worked for you.


Hi. My OPenGL is also working, and the only thing I did was to write the ; in win-ini and save, No reboot, nothing, everything worked fine just after. don't know what the DVA=0 is though...

Oops, the shiny days are back...

07-18-2000, 05:59 AM
See you at Quake Jose. He He

Maybe its win.ini that cause the problem.

Please everyone with geforce and tnt related cards give a respons in this topic.
If your open gl working or still not working after this formula. It will be a great help for others.

Its a shame that nvidia,creative and other manufactors seems to not know what we are talking about and more important what causes this problem.

cu!

toenail
08-01-2000, 08:07 PM
Looks like you have found the GeForce FAQ page also. I have found little from MS about DVA. I sent it to Minkus, and he recently modified the answer. It stands for Direct Video Access, and I only found old references to it for Win95, and even 3.xx!! It is/was supposed to allow video play straight to display and bypassing the GDI. At that time, disabling it (=0), was considered a fix for some games. It made things slower, but more stable. It was mostly a recognition of then current hardware & software. I think that one of the current players (Real, Media, etc.) Is inserting the disable switch.

08-03-2000, 09:15 PM
I believe DVA was the major problem with my open gl problem. The weirdest thing was that mine open gl work fine in the beginning and then suddenly stop working. I really dont remember what install that causes the problem (maybe detonators). Well now Im a bit afraid to install new drivers for my graphiccard or open gl. Do you know If there are any problems to install new detonator drivers or open gl drivers.

08-09-2000, 01:57 PM
I too got a problem with OpenGL on my Win98-Machine with a Hercules Dynamite TNT. Many Programs just crashed and e.g. Quake 3 gave the Error-Msg "could not load openGL subsystem". I tested OpenGL using the X29-Demo from 3D-Labs and it said "Renderer: GDI Generic". So OpenGL was running in Software-Mode. Thank God I made it to this Forum and after I just added the ";" to the DVA=0 line in the win.ini it finally works again. Thanks a lot! http://www.opengl.org/discussion_boards/ubb/smile.gif

08-16-2000, 10:34 AM
The DVA stuff did it for me as well with
Quake3 Arena on an Ahtlon 600 with a Guillemot GeForce.

Great !!!

Thanks a lot :-)

08-19-2000, 05:57 AM
what if u dont have the DVA=0 line in the win.ini

08-19-2000, 12:40 PM
what sort of card do you got Watto?

08-19-2000, 05:11 PM
CL Geforce, and its really pissin me off coz i cant play any games in OpenGL http://www.opengl.org/discussion_boards/ubb/frown.gif

08-20-2000, 01:42 AM
what motherboard do you got?

Have open gl ever worked for you?

and what do you have for graphic driver?

08-20-2000, 03:13 AM
athlon700
k7m motherboard <<< L8EST BIOS
128MB ram
cL geforce 6.11 drivers

and no opengl have never worked just randomly freezes on me http://www.opengl.org/discussion_boards/ubb/frown.gif

08-20-2000, 02:35 PM
I believe you got a via chipset on your mainboard. If thats the case try to download new AGP-driver
http://www.via.com.tw/drivers/index.htm

It have worked for some.

08-20-2000, 02:39 PM
I mean the 4-1 driver!!!!

08-21-2000, 01:48 AM
Are u sure my k7m uses the via chipset?

08-21-2000, 05:20 AM
Is this your board?
http://www.arstechnica.com/reviews/4q99/asusk7m/k7m-1.html

seems like Via

08-21-2000, 11:37 PM
Yes it is, but i have heard that the 4-1 via drivers are crappy, on the www.reactorcritical.com (http://www.reactorcritical.com) msg boards.

08-22-2000, 12:15 AM
Its a pity.
But Ive heard that the via chipset causes problem with openGL espicially the AGP-config
Maybe you can begin with changing the AGP-settings. I believe creative have some program(agp-wizard) that will do the job.