Part of the Khronos Group

Better syntax highlighting for GLSL

Nov 27, 2012

Sadly, syntax highlighting for GLSL shaders in QTCreator and Kate (KDE) didn’t catch up with the latest language definitions. This posting provides an updated syntax definition that supports up to GLSL 4.30 as well as shaders for OpenGL ES 2.0/3.0. Based on the #version definition inside of the shader it even is able to detect the language version and mark only available keywords, build-in variables and functions as such. Notes to install the free glsl.xml file are provided.

Category: DevelopersApplications

Posted on 11/27 at 05:37 PM

Comments

Love Kate editor and it is also used in KDevelop IDE so this will very useful. Thanks for the heads up.

Posted by Jure Repinc  on  12/13  at  12:59 PM

Leave a comment

Commenting is not available in this weblog entry.

<< Back to main

Column Header
Column Footer