Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 2 of 2

Thread: Compute Shader crashes / dynamic branching

  1. #1
    Newbie Newbie
    Join Date
    Dec 2013
    Posts
    3

    Compute Shader crashes / dynamic branching

    Hi everyone,
    I am trying to get some code running in my compute shader (#version 430 core, running under Windows 7, NVIDIA GeForce GTX 660) but it always crashes.
    The exact same code runs fine when I execute it in a fragment shader.
    I started commenting out parts of the code to find the solution to the problem.
    It seems like the compute shader always crashes when I reapply some of my dynamic branching.
    Does anyone know if the branching really could be the problem (hardware limitations, etc) and, if yes, how I can overcome that problem. Are there some clever hacks because I can't get rid of any branches.
    Also, the branching happens in a for-loop which runs in a while loop.
    Thanks a lot
    Last edited by bavarianbasti; 02-04-2014 at 03:22 AM.

  2. #2
    Newbie Newbie
    Join Date
    Dec 2013
    Posts
    3
    I think I found the part which got it to crash but i do not fully understand why that was the problem. It seems like my atomic counter got it to crash. When I commented it out, the crashes went away. I really have no clue why. If anyone has a good explanation I would be thrilled to hear it. Thanks a lot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •