Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 4 of 4

Thread: Linker Errors GLUT

  1. #1
    Newbie Newbie
    Join Date
    Dec 2013
    Posts
    3

    Linker Errors GLUT

    Hello everyone, I am new to the forum I am Brazilian, so do not be afraid of spelling errors (ahaha)
    Well .. straight to the point.
    I have a problem running any GLUT application. I am using Dev C + + 5.0 (4.9.9.2).

    this using the example application that creates Dev C when a project is created, by the way

    i've tried to post the errors here in this post, but my post was denied, do not know why.

    I posted here a picture showing the errors in the compiler:




    Thank you guys and help me please, m freaking out!
    Last edited by Dark Photon; 12-19-2013 at 07:25 PM.

  2. #2
    Senior Member OpenGL Guru Dark Photon's Avatar
    Join Date
    Oct 2004
    Location
    Druidia
    Posts
    3,194
    Looks like you just need to add the GLUT library to the list of libraries your application should link with. Make sure you've specified the correct path. Also verify that the format of the library is compatible with the application you are trying to build (e.g. don't try to link a 32-bit GLUT library with a 64-bit application, etc.)

  3. #3
    Newbie Newbie
    Join Date
    Dec 2013
    Posts
    3
    Thank you, could you tell where I can find the right file the glut for windows 64 bit system and where should I put it? (System32 or SysWOW64?)

    Thank you

  4. #4
    Senior Member OpenGL Guru Dark Photon's Avatar
    Join Date
    Oct 2004
    Location
    Druidia
    Posts
    3,194
    I would just leave it where FreeGLUT installs it.

    Somebody in the Windows forum can probably help you out. Moving your post there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •