Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: Anyone Else Experience Driver Update Issues?

  1. #1
    Junior Member Newbie
    Join Date
    Oct 2013
    Posts
    9

    Anyone Else Experience Driver Update Issues?

    I recently updated my drivers from OpenGL 3.2 to 4.3 and it seems to be interpreted differently. I was convinced this shouldn't impact legacy OpenGL.

    For example, when using a FBO to render to a texture of type GL_UNSIGNED_SHORT_5_6_5 in OpenGL 3.2 the quality was good. But after updating to 4.3 the quality is poor and blotchy. I changed this to GL_UNSIGNED_SHORT and it seems to have fixed it but there are a bunch of other issues I'm witnessing as well.

    Has anyone else experienced anything similar to this?

    I am using the fixed function pipeline as well as programmable and wonder if that has anything to do with it.

    Thanks
    Last edited by blabz2007; 10-10-2013 at 10:08 AM.

  2. #2
    Senior Member OpenGL Pro
    Join Date
    Jan 2007
    Posts
    1,136
    A possible explanation is your hardware vendor tightening up their conformance. In older OpenGL your vendor may have been silently promoting your requested 565 format to something with greater precision, which is allowed; with the 4.3 driver, when you ask for a 565 format that might just be exactly what you get.

  3. #3
    Senior Member OpenGL Pro
    Join Date
    Jan 2012
    Location
    Australia
    Posts
    1,101
    With 4.3 driver you can find out if your card supports an internal format with glGetInternalformativ

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •