When I try to compile my OpenGL 4 program on Ubuntu 12.04 I get the following error:
undefined reference to `glPatchParameteri'|
I am including the OpenGL headers as follows:
Code :
#include <OpenGL.h>
#include <GL/gl.h>

This macro is defined in the project build options:
GL_GLEXT_PROTOTYPES
According to the terminal, my GPU supports OpenGL 4.3:
Code :
OpenGL version string: 4.3.0 NVIDIA 319.32

I have not included GLEW, as I have never needed it in the past, and do not know if it solves this problem.