Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: Conflict in OpenGL versions and hardware issues

  1. #1
    Newbie Newbie
    Join Date
    Sep 2013
    Posts
    2

    Conflict in OpenGL versions and hardware issues

    I have been using two Python modules that use OpenGL - Psychopy and VisionEgg; since, the question is related to OpenGL and the corresponding hardware, I am posting it here. When trying to run programs on either of these, I get errors saying that OpenGL version 1.3 is required. So, I installed the latest drivers (Catalyst 6.11) for my Video card (Radeon 9000 Pro), on a Windows XP Professional SP 3 setup. After doing this, when I checked my OpenGL version using GLView, it displayed v1.3; the OpenGL driver version is 6.14.00.(something like that). But, one of the programs still reports OpenGL as v1.1, while the other detects v1.3.

    When I now run the program on Psychopy, there are no errors, but, after a window is rendered, no further objects are displayed. Besides, certain colours, text, images, icons etc. disappear from windows altogether making me partially blind to using the pc. When I look at my desktop now, all icons are gone, only the shortcuts names are displayed. It is restored only on restart of my pc.

    And, the report on running some code to check the config shows the following detail:

    OpenGL info:
    vendor: ATI Technologies Inc.
    rendering engine: RADEON 9000 PRO DDR x86/SSE2
    OpenGL version: 1.3.1072 WinXP Release
    (Selected) Extensions:
    True GL_ARB_multitexture
    False GL_EXT_framebuffer_object
    False GL_ARB_fragment_program
    False GL_ARB_shader_objects
    False GL_ARB_vertex_shader
    False GL_ARB_texture_non_power_of_two
    False GL_ARB_texture_float
    False GL_STEREO
    max vertices in vertex array: 2147483647

    When I run the Vision Egg program, it displays an error saying that OpenGL v1_1 is detected and OpenGL v1_3 is required. It says that the default Microsoft drivers are being loaded and asks me to upgrade my video card drivers.
    Error:
    2013-09-05 12:18:50,421 (4088) INFO: Script D:\displayText.py started Vision Egg 1.2.1 with process id 4088.
    2013-09-05 12:18:52,921 (4088) INFO: Requesting window 640 x 480 32 bpp (8 8 8 0 RGBA).
    2013-09-05 12:18:53,592 (4088) INFO: OpenGL 1.1.0, GDI Generic, Microsoft Corporation (PyOpenGL 3.0.2a6)
    2013-09-05 12:18:53,592 (4088) WARNING: Using default Microsoft Windows OpenGL drivers. Please (re-)install the latest video drivers from your video card manufacturer to get hardware accelerated performance.
    2013-09-05 12:18:53,592 (4088) INFO: Video system reports 32 bpp (8 8 8 0 RGBA).
    2013-09-05 12:18:53,655 (4088) WARNING: Unable to detect or automatically synchronize buffer swapping with vertical retrace. May be possible by manually adjusting video drivers. (Look for 'Enable Vertical Sync' or similar.) If buffer swapping is not synchronized, frame by frame control will not be possible. Because of this, you will probably get a warning about calculated frames per second different than specified.
    2013-09-05 12:18:53,717 (4088) WARNING: Could not initialize OpenGL.GL.ARB.multitexture -- some features will be missing.
    2013-09-05 12:18:53,717 (4088) WARNING: multitexturing not available. Some features will not be available

    Traceback (most recent call last):
    File "D:\displayText.py", line 32, in <module>
    pFix.go()
    File "C:\Python27\lib\site-packages\VisionEgg\FlowControl.py", line 395, in go
    viewport.draw()
    File "C:\Python27\lib\site-packages\VisionEgg\Core.py", line 1374, in draw
    stimulus.draw()
    File "C:\Python27\lib\site-packages\VisionEgg\Text.py", line 179, in draw
    VisionEgg.Textures.TextureStimulus.draw(self) # call base class
    File "C:\Python27\lib\site-packages\VisionEgg\Textures.py", line 1465, in draw
    self.texture_object.set_wrap_mode_s( p.texture_wrap_s )
    File "C:\Python27\lib\site-packages\VisionEgg\Textures.py", line 506, in set_wrap_mode_s
    gl.glTexParameteri( self.target, gl.GL_TEXTURE_WRAP_S, wrap_mode)
    File "C:\Python27\lib\site-packages\OpenGL\error.py", line 208, in glCheckError
    baseOperation = baseOperation,
    GLError: GLError(
    err = 1280,
    description = 'invalid enumerant',
    baseOperation = glTexParameteri,
    cArguments = (
    GL_TEXTURE_2D,
    GL_TEXTURE_WRAP_S,
    GL_CLAMP_TO_EDGE,
    )
    Why is there this conflict in detecting the OpenGL versions in the two programs? While Psychopy reports that OpenGL.GL.ARB.multitexture exists, VisionEgg says 'Could not initialize OpenGL.GL.ARB.multitexture'.
    I don't seem to have any other display adapters. I don't see why the drivers used are different for the two modules. When I check Device Manager, though, there are two display drivers shown, both, Radeon 9000, but one of them also says '(secondary)'. A solution that does not involve a hardware upgrade is something I would like better. Thank you

  2. #2
    Member Regular Contributor
    Join Date
    Jun 2013
    Posts
    498
    First, I'd suggest completely removing any existing video drivers, using "Driver Sweeper" to clean up anything which is left behind. After a reboot, Windows should be running at 640x480. Then install the latest drivers.

    The reason for this is that ATI/AMD driver upgrades are ... somewhat less than reliable. This may not actually be the problem, but the probability is high enough to be worth making sure.

  3. #3
    Newbie Newbie
    Join Date
    Sep 2013
    Posts
    2
    I did remove the drivers using the AMD uninstall utility, rebooted windows with no drivers and then installed the new one. But, like you said, it is possible that wasn't enough to remove all related files. I'll try what you suggested. Thank you!

    Quote Originally Posted by GClements View Post
    First, I'd suggest completely removing any existing video drivers, using "Driver Sweeper" to clean up anything which is left behind. After a reboot, Windows should be running at 640x480. Then install the latest drivers.

    The reason for this is that ATI/AMD driver upgrades are ... somewhat less than reliable. This may not actually be the problem, but the probability is high enough to be worth making sure.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •