is there any glsl for my opengl 3.1? i searched in google and no luck all different versions cause when i use different versions it creates syntax errors.
also if i do :

#version 330

is it for the other versions?

so if i got the glsl for my 3.1 what version do i put?
thanks