Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: GLSL Shading Language for my opengl 3.1 any?

  1. #1
    Junior Member Newbie
    Join Date
    Aug 2013
    Posts
    8

    GLSL Shading Language for my opengl 3.1 any?

    is there any glsl for my opengl 3.1? i searched in google and no luck all different versions cause when i use different versions it creates syntax errors.
    also if i do :

    #version 330

    is it for the other versions?

    so if i got the glsl for my 3.1 what version do i put?
    thanks

  2. #2
    Senior Member OpenGL Guru Dark Photon's Avatar
    Join Date
    Oct 2004
    Location
    Druidia
    Posts
    3,213
    Quote Originally Posted by FinkPotato View Post
    is there any glsl for my opengl 3.1? i searched in google and no luck all different versions cause when i use different versions it creates syntax errors. ...so if i got the glsl for my 3.1 what version do i put?
    If memory serves, you want GLSL version 1.4 to get the absolute latest for that OpenGL version, so use #version 140.

    OpenGL 3.3 was when they started syncing up the GL and GLSL version numbers IIRC (3.3 -> #version 330, 4.0 -> #version 400, etc.) Before that the correspondence was a bit odd (3.2 -> 1.5 == #version 150, 3.1 -> #version 140, etc.)

  3. #3
    Junior Member Newbie
    Join Date
    Aug 2013
    Posts
    8
    So pls can I have a link to the 1.4 cause I just searched for a long time but no luck

  4. #4
    Advanced Member Frequent Contributor arekkusu's Avatar
    Join Date
    Nov 2003
    Posts
    782
    It's on opengl.org, right next to all of the other specifications:

    http://www.opengl.org/registry/

  5. #5
    Junior Member Newbie
    Join Date
    Aug 2013
    Posts
    8
    there all different versions and no downloads.i want 1.4

  6. #6

  7. #7
    Junior Member Newbie
    Join Date
    Aug 2013
    Posts
    8
    Umm I'm talking about glsl syntax highlight version 1.40 not the opengl version.

  8. #8
    Senior Member OpenGL Guru
    Join Date
    May 2009
    Posts
    4,948
    You never said anything about syntax highlighting. Syntax highlighting for what IDE? This is something that Google would probably be better to find.

  9. #9
    Junior Member Newbie
    Join Date
    Aug 2013
    Posts
    8
    Cant cause there all different versions like I said

  10. #10
    Senior Member OpenGL Guru
    Join Date
    May 2009
    Posts
    4,948
    It's a syntax highlighter; it's not essential tech for using OpenGL. If the version of the highlighter is off a bit, so what? Just restrict yourself from using non 1.40 features. And your compiler should do that for you well enough.

    Plus, nobody can tell you what syntax highlighter to use for your IDE without knowing what your IDE is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •