Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 4 of 4

Thread: Android , why GLSurfaceview output is differ in Devices (Google Nexux7,Sam G Note II)

  1. #1
    Newbie Newbie
    Join Date
    Jul 2013
    Posts
    2

    Post Android , why GLSurfaceview output is differ in Devices (Google Nexux7,Sam G Note II)

    I have created an android app for drawing of lines,circles.. by using GLSurfaceView in OpenGLES 2.0 like an Auto cad app. The app works well with Google Nexus 7, in the sense that if we draw a line & then a circle the line doesn't get erased in surface view But with Samsung Galaxy Note II, it is entirely different. The line previously drawn before a circle being drawn, gets erased. i.e., each time if we draw a new line or circle, the previous one gets erased.I can draw only one image at a time. What I need is the same output which I get in Google Nexus 7 in Samsung Galaxy Note II. .e.I want to draw more than one image in the GLSurfaceView at a time.

    Note : Both the Android OS in Google Nexus 7 and Samsung Galaxy Note II are Jelly Bean 4.2. But both devices are different GPU. Google Nexus 7 GPU is ULP GeForce & Samsung Galaxy Note II is Mali400MP.

    Would this be an issue in the rendering of output of the Surfaceview ?

    Should we take into account of GPU while Coding ?

    Can anyone tell me why this problem of different output in different devices ?

    Thanks Advance..

  2. #2
    Member Regular Contributor Nowhere-01's Avatar
    Join Date
    Feb 2011
    Location
    Novosibirsk
    Posts
    251
    really? coding? you can't even choose appropriate sub-forum to post your nonsensical questions.

    P.S. initially, this topic was created in Items of importance.
    Last edited by Nowhere-01; 07-08-2013 at 10:39 AM.

  3. #3
    Super Moderator OpenGL Guru dorbie's Avatar
    Join Date
    Jul 2000
    Location
    Bay Area, CA, USA
    Posts
    3,946
    You must develop an understanding of how you are rendering and to what type of surface. The issue you are encountering may be caused by double buffering vs. single buffering but if you are using a library for rendering other than low level OpenGL ES then it could be anything. You should not need to worry about which GPU you are using for basic OpenGL ES where it makes a difference is when it comes to extensions and compressed texture formats. You are probably rendering with assumptions that do not hold across systems or you are implicitly making assumptions that you are unaware of.

  4. #4
    Junior Member Newbie
    Join Date
    Jun 2013
    Posts
    25
    Don't let the name "GLSurfaceview" fool you. That appears to be an Android API call, not OpenGL. Aside from that, maybe there is someway for you to explicitly disable the clear screen function, it sounds like this is the issue.

    I just found this... Maybe it will help. http://stackoverflow.com/questions/1...aring-behavior

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •