Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 6 of 6

Thread: glew does not fetch glDrawArraysInstancedBaseInstance

Hybrid View

  1. #1
    Junior Member Newbie
    Join Date
    May 2011
    Posts
    16

    glew does not fetch glDrawArraysInstancedBaseInstance

    I'm trying to use glDrawArraysInstancedBaseInstance but the linker complains that __glewDrawArraysInstancedBaseInstance is unresolved.
    glew-1.9.0 is installed on the machine and as far as I can tell, it should be linking it.
    As temporary work around, I'm just fetching the function myself, which works. But it does not help me understand why glew does not appear to be working for that function.
    And actually glew does not appear to be working for anything opengl 3.3+
    I'm using glfw to create my window and a 4.3 core profile context
    My system:
    NVidia gtx 550 ti, with latest drivers
    Ubuntu 12.04

    Using CMake for the make files and in CMakeLists.txt
    target_link_libraries(app GL GLU GLEW glfw)

    using
    glewExperimental = true; before glewInit()

    and
    glfwExtensionSupported("GL_ARB_base_instance")
    to verify that the function is available.

    Last edited by tamato; 07-16-2013 at 09:26 AM.

  2. #2
    Member Regular Contributor Nowhere-01's Avatar
    Join Date
    Feb 2011
    Location
    Novosibirsk
    Posts
    251
    try setting glewExperimental = true; before calling to glewInit();

  3. #3
    Junior Member Newbie
    Join Date
    May 2011
    Posts
    16
    Already doing that.

  4. #4
    Member Regular Contributor Nowhere-01's Avatar
    Join Date
    Feb 2011
    Location
    Novosibirsk
    Posts
    251
    check your linking setting, then. i'm not familiar with unix-like operating systems, but someone else here might be, and you didn't specify how do you link to a Glew library for them to help you.

  5. #5
    Advanced Member Frequent Contributor
    Join Date
    Apr 2010
    Posts
    741
    I suspect the version of glew that comes with your distro does not yet contain that entry point (same here on Fedora 17: grepping for DrawArraysInstancedBaseInstance through all files in /usr/include/GL only shows hits in glext.h not in glew.h). You'll have to build your own version of glew or use a different loader library.

  6. #6
    Junior Member Newbie
    Join Date
    May 2011
    Posts
    16
    It turns out to be that when installing glew-1.9.0, it was being installed to /usr/lib64 and this was only one of the two problems that were happening.
    One of the problems was that glew-1.7.0 was installed in /usr/local/lib64, and my app was using this version of glew.

    • I found this by doing find /usr -name libGLEW*

    And the other was that ldconfig did not know about /usr/lib64.

    • This was found by doing ldconfig -p > report.txt and looking to see what directoriesldconfig was looking in. Which turned out to be helpful because I thought /usr/lib64 was a "trusted" directory, and that was not the case.

    Armed with this information glew-1.7.0 was removed, ldconfig was updated and now everything works as expected.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •