Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: Mesa-9.1.3 Install Error on Windows XP using scons ..auxiliary\libgallium.a] Error 1

  1. #1
    Newbie Newbie
    Join Date
    May 2013
    Posts
    2

    Question Mesa-9.1.3 Install Error on Windows XP using scons ..auxiliary\libgallium.a] Error 1

    Im trying to add support for OpenGL 2.0 in my WindowsXP Professional system, a Quad ATOM board from Intel. As the drivers shows level 1.4 I decided to install the Mesa3D package version 9.1.3.

    For install Ive chose the "scons" process via Python, whchs seems to run OK. During the build I get a consusing message which is:

    scons: *** [build\windows-x86-debug\gallium\auxiliary\libgallium.a] Error 1

    I ve also tested with older distributions, same error. The error happens when running comands:

    cons
    or
    scons build=debug libgl-gdi

    See the detailed log below:

    C:\Documents and Settings\Intel\Meus documentos\downloads\Kivy\OpenGL\Mesa-9.1.3
    >scons build=debug libgl-gdi
    scons: Reading SConscript files ...
    Checking for X11 (x11 xext xdamage xfixes)... no
    Checking for XCB (x11-xcb xcb-glx >= 1.8.1)... no
    Checking for XF86VIDMODE (xxf86vm)... no
    Checking for DRM (libdrm >= 2.4.24)... no
    Checking for DRM_INTEL (libdrm_intel >= 2.4.30)... no
    Checking for DRM_RADEON (libdrm_radeon >= 2.4.42)... no
    Checking for XORG (xorg-server >= 1.6.0)... no
    Checking for KMS (libkms >= 2.4.24)... no
    Checking for UDEV (libudev > 150)... no
    warning: LLVM disabled: not building llvmpipe
    scons: done reading SConscript files.

    scons: warning: you do not seem to have the pywin32 extensions installed;
    parallel (-j) builds may not work reliably with open Python files.
    File "C:\Python27\Scripts\scons.py", line 192, in <module>
    scons: Building targets ...
    Archiving build\windows-x86-debug\mesa\libmesa.a ...
    Archiving build\windows-x86-debug\gallium\auxiliary\libgallium.a ...
    Generating build\windows-x86-debug\glsl\glsl_lexer.cpp ...
    scons: *** [build\windows-x86-debug\mesa\libmesa.a] Error 1
    Generating build\windows-x86-debug\glsl\glsl_parser.cpp ...
    scons: *** [build\windows-x86-debug\gallium\auxiliary\libgallium.a] Error 1
    src\glsl\glsl_parser.yy: conflicts: 1 shift/reduce
    scons: building terminated because of errors.

    Thanks in advance for any insight how to fix the build .

    Regards.
    Claude

  2. #2
    Senior Member OpenGL Pro
    Join Date
    Apr 2010
    Location
    Germany
    Posts
    1,099
    Ok, you can use MESA on Windows. But why the hell would you? What machine is this exactly? Intel Atom doesn't say much ...

  3. #3
    Newbie Newbie
    Join Date
    May 2013
    Posts
    2
    Dear Thokra.
    Hardware:
    Intel ACPI Multiprocessor PC - Quad Atom Mini-ITX Board with Intel Graphics Media Accelerator 3150 (with updated drivers)
    Reason: Need to install an Android Dev Platform which requires OpenGL2 like Kivy, or Google ADT. For web and math, this board runs fast with low energy consumption. Thanks for any hint how to build the Mesa package on XP to replace the OpenGL.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •