Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: Z-Axis blocking my Graph Line/Data

  1. #1
    Junior Member Newbie
    Join Date
    Apr 2013
    Posts
    10

    Z-Axis blocking my Graph Line/Data

    Hey guys...

    I can't figure out why this is happening, but whenever I put up the QUADS/PLANES for the 3d-like walls, they "cover" or block out the data line...
    I'm stuck :/

    i45 dot tinypic dot com/2h7o0lk.png

    It's giving me problems with attaching images/urls...

    There is the result.

    Thanks in advance
    -Mike

  2. #2
    Junior Member Newbie
    Join Date
    Apr 2013
    Posts
    5
    Do you have depth buffering enabled? Enable it thusly in your initialization section:
    Code :
    glEnable(GL_DEPTH);
    glDepthFunc(GL_LESS);
    And be sure you clear *both* the color buffer and the depth buffer in your render routine, or only the first render will be correct:
    Code :
    glClear(GL_COLOR_BUFFER_BIT | GL_DEPTH_BUFFER_BIT);
    Depth buffering causes fragments with a lower depth buffer value to be "in front" of other fragments with higher depth buffer values, when using the GL_LESS depth buffering function.

  3. #3
    Junior Member Newbie
    Join Date
    Apr 2013
    Posts
    10
    Thanks for the quick response.

    I have ensured that those bits of code are in the program.

    This is the result...

    The bottom view is okay, but not from the top.

    i47 dot tinypic dot com/rkyog3.png

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •