Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 10 of 18

Thread: nvidia driver 310.xx or newer

Hybrid View

  1. #1
    Junior Member Regular Contributor
    Join Date
    Feb 2007
    Location
    Hungary
    Posts
    168

    nvidia driver 310.xx or newer

    Hi,
    I have been working on an application based on OpenGL 2.1.
    For several years, no Nvidia driver has given me any trouble, I periodically downloaded and installed the new version with no issues whatsoever. Since version 310.90 or newer, my application can initialize a rendering context, FBO, etc., but then it crashes at various opengl function calls (if I comment out one 'culprit', then there will be another, etc.).
    Is there any change in these new drivers, is maybe Open GL 2.1 support dropped? If this is not the right place to ask help with this problem, can someone point me in the right direction?
    Thanks.
    p.s. I almost forgot that I use Win7 64-bit and my range of cards include the GTX2xx, 5xx and 6xx line, and it doesn't matter which of these I try, they all crash with the new driver but work with any driver before 310.90

  2. #2
    Member Regular Contributor malexander's Avatar
    Join Date
    Aug 2009
    Location
    Ontario
    Posts
    302
    Our users also experienced hangs and crashes when using 310+ on Windows 8, which we reported to Nvidia. They resolved the issue in the Quadro 311.15 driver, but the GEforce driver is still not patched, though a fix may be forthcoming in 319. In the meantime, we've advised Win8 users to use 306 or below.

  3. #3
    Junior Member Regular Contributor
    Join Date
    Feb 2007
    Location
    Hungary
    Posts
    168
    Quote Originally Posted by malexander View Post
    Our users also experienced hangs and crashes when using 310+ on Windows 8, which we reported to Nvidia. They resolved the issue in the Quadro 311.15 driver, but the GEforce driver is still not patched, though a fix may be forthcoming in 319. In the meantime, we've advised Win8 users to use 306 or below.
    Did this happen only on Windows 8 but on Windows 7 and was it the 64-bit version? Thanks.

  4. #4
    Member Regular Contributor malexander's Avatar
    Join Date
    Aug 2009
    Location
    Ontario
    Posts
    302
    Only happened on Windows 8 64b. Linux 64b and Windows 7 64b and Vista 64b were fine. We no longer support 32b OSes, so I'm not sure if those are affected or not.

  5. #5
    Junior Member Regular Contributor
    Join Date
    Feb 2007
    Location
    Hungary
    Posts
    168
    Quote Originally Posted by malexander View Post
    Only happened on Windows 8 64b. Linux 64b and Windows 7 64b and Vista 64b were fine. We no longer support 32b OSes, so I'm not sure if those are affected or not.
    I support 32-bit any more either, but my OS is Win7. Can you tell me which version of OpenGL yours is based on and where can I report something like this to Nvidia?
    Thanks.

  6. #6
    Member Regular Contributor malexander's Avatar
    Join Date
    Aug 2009
    Location
    Ontario
    Posts
    302
    We're registered as a partner with Nvidia (https://partners.nvidia.com/Login.aspx), but there's also the developer zone which I believe has a forum (https://developer.nvidia.com/categor...cs-development). Detailed, reproducible bug reports are the key to getting driver issues resolved.

    Our app seemed to hang after creating/switching GL contexts a bunch of times. Eventually it'd be unable to make a context current. It didn't seem like the actual OpenGL code mattered, perhaps it was a WGL issue.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •