Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 8 of 8

Thread: OpenGL and Mesa for MythTV

Hybrid View

  1. #1
    Junior Member Newbie
    Join Date
    Feb 2013
    Posts
    4

    OpenGL and Mesa for MythTV

    It appears that hardware accel is working on my machine, but it still shows the pesky Mesa. I've deinstalled everything Mesa-related that won't destroy my system, but it stubbornly stays. nVidia Quadro FX 2800M with manually-installed binary driver.

    What is this, and how can I fix it?
    Last edited by Quantum; 02-12-2013 at 04:59 PM.

  2. #2
    Junior Member Newbie
    Join Date
    Feb 2013
    Posts
    11
    You are running inside a VMware virtual machine.

  3. #3
    Junior Member Newbie
    Join Date
    Feb 2013
    Posts
    4
    No, this is actually on the main machine. I don't even have VMware installed. I run x2go. This is an HP EliteBook 8740w notebook.

    And I get a very similar string on my HTPC, which is an Asus ATX mobo with built-on nVidia 9300 chip. Again, right on the hardware and no VMware installed.

    Hm, I read that llvmpipe means it's doing software rendering.

    In Xorg.0.log I find:
    Code :
    Failed to initialize the GLX module; please check in your X
    log file that the GLX module has been loaded in your X
    server, and that the module is the NVIDIA GLX module.  If
    you continue to encounter problems, Please try
    reinstalling the NVIDIA driver.
    Well, this -is- the X log file. Further up it says:
    Loading extension GLX(EE) NVIDIA(0):
    ... but no version number or other info, as if it can't find the module.

    I'm compiling the nVidia driver manually, not using the one from the repo.

    Why would it not be finding GLX?
    Last edited by Quantum; 02-12-2013 at 03:55 PM.

  4. #4
    Senior Member OpenGL Guru Dark Photon's Avatar
    Join Date
    Oct 2004
    Location
    Druidia
    Posts
    3,194
    > lsmod | grep nvidia

    > grep nvidia /etc/X11/xorg.conf

    > ldd `which glxinfo`

    > ls -l /usr/lib/libGL.so.1 /usr/lib64/libGL.so.1

  5. #5
    Junior Member Newbie
    Join Date
    Feb 2013
    Posts
    4
    Thanks but I've found the problem. xorg wasn't able to load the GLX extension for the compiled nVidia driver, because the X development files were not installed! I installed the metapackage xorg-dev, rebooted into recovery, recompiled the video driver, rebooted, and now by Jove I get this:
    Code :
    # glxinfo
    ...
    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: Quadro FX 2800M/PCIe/SSE2
    OpenGL version string: 3.3.0 NVIDIA 310.32
    OpenGL shading language version string: 3.30 NVIDIA via Cg compiler
    ...

    Only thing is, now glxgears is back down to ~60fps. With the VMware software driver I was getting 500fps. Any idea why?

  6. #6
    Senior Member OpenGL Guru Dark Photon's Avatar
    Join Date
    Oct 2004
    Location
    Druidia
    Posts
    3,194
    > env __GL_SYNC_TO_VBLANK=0 glxgears

    You likely have an LCD monitor, which refreshes at 60Hz, and sync-to-vblank is on by default.

    nvidia-settings under GPU 0 (CRT-0 tab here) will tell you what its got the refresh rate set to. Here I get 97Hz (I'm not on an LCD).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •