Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 1 of 1

Thread: weird color problem with openGL

Threaded View

  1. #1
    Newbie Newbie
    Join Date
    Feb 2013
    Posts
    1

    Question weird color problem with openGL

    Hi there,

    I got a pretty weird problem with colors and openGL. Since I got my new computer some openGL applications won't draw some spezific colors.
    The first time I took notice was while playing Quake Live. I changed the color of my crosshair to #00ff00 and it became black or transparent while moving it over very dark or black textures. The same with a bright blue color like #0020e0.
    The second time I took notice of this problem was, when I worked in photoshop. bright colors became black.... after I deactivated the openGL acceleration in photoshop, all colors were drawn correctly.

    I found out that every color is affected, which is created by the RGB code R "0" ; G "0" ; B "x" or R "0" ; G "x" ; B "0" or R "0" ; G "x" ; B "x"
    x= value between 1 and 255
    Which means green and blue are the problems when red always has the value "0". Even if there is just the value "1" at red, the color is not just black.
    I got the problem with older drivers aswell.
    by the way: there are no problems in windows generally drawing the colors. If a website or a picture includes this colors, there isn't any problem.

    my system:
    windows 7 64bit service pack 1
    catalyst 12.11 beta drivers
    amd fx
    radeon 7870
    Last edited by floh667; 02-03-2013 at 10:09 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •