Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: Can I programming OpenGL4+ in a card that support 2.1 only?

Hybrid View

  1. #1
    Junior Member Newbie
    Join Date
    Nov 2008
    Posts
    5

    Question Can I programming OpenGL4+ in a card that support 2.1 only?

    This is the OpenGL version I have:

    Code :
    Video Card Vendor:    Intel
    Renderer:             Intel(R) HD Graphics
    OpenGL Version:       2.1.0 - Build 8.15.10.2622
    GLU Version:          1.2.2.0 Microsoft Corporation

    I'd like to know if I can programing in OpenGL 4+. Because I cannot update my card.

  2. #2
    Advanced Member Frequent Contributor
    Join Date
    Dec 2007
    Location
    Hungary
    Posts
    985
    Unless your card and driver supports OpenGL 4+ you cannot use it. Most likely in your case you are stuck with GL 2.1. You need to get a more recent AMD or NVIDIA GPU (I don't think Intel has any card/driver that supports GL 4.x yet) and get the latest drivers. Radeon HD5000+ and GeForce 400+ have GL 4.x support.
    Disclaimer: This is my personal profile. Whatever I write here is my personal opinion and none of my statements or speculations are anyhow related to my employer and as such should not be treated as accurate or valid and in no case should those be considered to represent the opinions of my employer.
    Technical Blog: http://www.rastergrid.com/blog/

  3. #3
    Senior Member OpenGL Pro Aleksandar's Avatar
    Join Date
    Jul 2009
    Posts
    1,146
    Can you tell us the exact model of your CPU?
    If it is a third generation Intel Core i-processor (with HD2500/HD4000 graphics card), then yes.
    Otherwise - NO!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •