Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: Alt + Tab not working with my OpenGL app

  1. #1
    Intern Contributor
    Join Date
    Oct 2011
    Posts
    52

    Alt + Tab not working with my OpenGL app

    Under win7 when I use Alt+Tab my app loses focus but its not minimized, it stays there in fullscreen. I have to use Ctrl+Alt+Del. (I dont know if it has anything to do with it but the debugger doesnt work either when my app runs in an opengl window)
    On my laptop under winXP it works fine. (maybe because of the different openGL versions?)
    (Im developing with C++ and NetBeans7.2)
    I have no idea whats wrong. help! Thanks!

  2. #2
    Senior Member OpenGL Pro
    Join Date
    Apr 2010
    Location
    Germany
    Posts
    1,128
    Absolutely not an OpenGL question - much less an advance OpenGL question.

    BTW, switching windows with Alt+Tab should not lead to a window being minimized and I for one don't recall this as the standard behavior of Windows XP. If you want to realize something like that you should re-implement an event handler that's handling the loss of focus - if there is such a thing in the windowing toolkit you're using.

    A debugger not working either means that you don't have a console debugger installed with NetBeans (if, which I don't know, NetBeans is able to use the Visual C++ tool chain) or you don't have debug information with your binaries. Other then that I don't know any causes of a debugger refusing to work, other than the debugger being buggy itself.

  3. #3
    Intern Contributor
    Join Date
    Oct 2011
    Posts
    52
    Thanks! I solved both problems by reinstalling MinGW and MySys and by handling the lose-focus event with "ShowWindow( hWnd, SW_MINIMIZE)"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •