Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: OpenGl in cs1.6

  1. #1
    Junior Member Newbie
    Join Date
    May 2012
    Posts
    1

    OpenGl in cs1.6

    After a year i started playing cs 1.6 again and now i have a problem when i run it in OpenGL mode. It looks like this http://i1209.photobucket.com/albums/...xInt/blur1.png, and as most of you probably know thats now that its supposed to look like

    Fps as far as iv seen is still the same, runs smoothly on 99 or 131 without fluctuating(the picture was taken when i ran cs in "integrated graphics" wich severly drops my fps when i look at larger areas of the map, but when i manualy pick "run with High performance NVIDIA proccesor" it runs at 131 fps.-

    When i run the game in d3d, it looks just like it used to without problems(exept i see no bullet marks on walls and lower fps, dont know the reason). In addition to this after this year i can no longer set nvidia graphics card as my default graphics card on hl.exe(wich i used to be able to do) and i just cant figure out what the problem is.

    I have tried uninstalling and reinstalling 2 different drivers, i tried looking up solutions on google, none of wich made any difference.
    i tried changing my screen resolution to match the game resolution, tried different graphics settings in nvidia control panel(like aa,anistropic filtering,ambient occlusion, and texture filtering quality). i also tried chancing ingame quality settings like texture quality and model quality, but i saw no differance even when i turned it from best to worst.

    So any help would be really appreciated as i have no idea what to try.

    EDIT: actually i just tried on going to the same spot on the map with both intergrated graphics and nvidia proccessor, so im guessing that even when i click "run with nvidia proccessor" it still runs it in integrated graphics, wich leads to this kind of look. So now the question is why does it not run with nvidia proccessor?

  2. #2
    Super Moderator OpenGL Guru
    Join Date
    Feb 2000
    Location
    Montreal, Canada
    Posts
    4,264
    It looks like a quality settings that needs to be changed from the nvidia control panel (if it is using the nvidia) or the Intel control panel.
    It look like it is using higher mipmap levels which of course are of lower rez and can improve performance but it looks like shit.
    So increase the texture quality. Set it to max.

    You may have to install the nvidia driver to have the control panel thing from nvidia.
    ------------------------------
    Sig: http://glhlib.sourceforge.net
    an open source GLU replacement library. Much more modern than GLU.
    float matrix[16], inverse_matrix[16];
    glhLoadIdentityf2(matrix);
    glhTranslatef2(matrix, 0.0, 0.0, 5.0);
    glhRotateAboutXf2(matrix, angleInRadians);
    glhScalef2(matrix, 1.0, 1.0, -1.0);
    glhQuickInvertMatrixf2(matrix, inverse_matrix);
    glUniformMatrix4fv(uniformLocation1, 1, FALSE, matrix);
    glUniformMatrix4fv(uniformLocation2, 1, FALSE, inverse_matrix);

  3. #3
    Junior Member Regular Contributor
    Join Date
    Dec 2009
    Posts
    212
    I think you have to set the parameter /cl_picmip to 0 in your game config.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •