Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: OpenGL does not allow 'mediump' after 'inout'

  1. #1
    Junior Member Newbie
    Join Date
    Sep 2009
    Location
    Paderborn, Germany
    Posts
    6

    OpenGL does not allow 'mediump' after 'inout'

    Hello,

    at the moment I'm writing some GLSL shaders.
    These shaders are for the OpenGL 4.1 core profile and should be compatible with OpenGL ES 2.0.

    mediump in vec3 normalVector;
    This is an excerpt from one of my vertex shaders.
    This works fine in Linux.
    The same shader in Windows throws the error
    OpenGL does not allow 'inout' after 'mediump'
    If I switch the order of the qualifiers to
    in mediump vec3 normalVector;
    it works in Windows but throws the opposite error message in Linux.
    OpenGL does not allow 'mediump' after 'inout'
    I use a nVidia card with driver version 280.13 with Linux and the newest current driver for Windows.

    What am I doing wrong?
    What is the correct order for the qualifiers?
    Any ideas?

    Thanx in advance,
    TheAvatar

  2. #2
    Senior Member OpenGL Guru
    Join Date
    May 2009
    Posts
    4,948

    Re: OpenGL does not allow 'mediump' after 'inout'

    According to the GLSL 4.1 spec, the precision qualifier should come after the parameter-qualifier (`in`, `out`, etc). So the Windows driver seems to be correct here.

  3. #3
    Junior Member Newbie
    Join Date
    Sep 2009
    Location
    Paderborn, Germany
    Posts
    6
    Thanks for clearing that up.

    Yesterday, I upgraded my Linux drivers to 295.x and now Windows and Linux show the same precision qualifier preference.
    So it actually seems to be a driver-related issue with the 280 driver for Linux.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •