Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 4 of 4

Thread: GM965 Chipset, Blender, Open GL

  1. #1
    Junior Member Newbie
    Join Date
    Jan 2008
    Posts
    2

    GM965 Chipset, Blender, Open GL

    Hi,

    I'm running XP on a Panasonic CF-R7 laptop with an Intel GM965 chipset, and mainly interested in working with Blender. I downloaded and installed the latest Intel driver, although I'm a bit puzzled because the version number, 14.32.3, is not what shows up when I output the DiagnosticReport, which tells me my driver version is 6.14.10.4906.

    Mostly Blender behaves fine, but there's a strange problem, where menu items do not highlight in realtime as they are selected (I can still select them) and text boxes do not give any feedback--I can write something in a text box, but cannot see what I'm writing, which is a big problem.

    A Blender coder told me that this probably has to do with the front buffer not displaying properly. I have played around with the OpenGL settings in the driver dialogs, flipping policy, triple buffer, etc. But I haven't made any progress.

    Any help on this would be most appreciated.

    T

  2. #2
    Senior Member OpenGL Pro sqrt[-1]'s Avatar
    Join Date
    Jun 2002
    Location
    Australia
    Posts
    1,000

    Re: GM965 Chipset, Blender, Open GL

    Where are you getting the Diagnostic Report from? the driver version 6.14.10.4906 is most likely for a Nvidia card, not an Intel chipset. Perhaps your OpenGL driver is not installed correctly and it is falling back to software?

    Perhaps you should try some of the links off the wiki page?
    http://en.wikipedia.org/wiki/Intel_GMA

    (From what I can find the Panasonic CF-R7 uses Intel X3100 integrated graphics - which is the GM965 chipset)

    Edit : Opps - it seems it is not just Nvidia drivers that use the 6.14.10 starting part - looks like most XP drivers do.

  3. #3
    Junior Member Newbie
    Join Date
    Jan 2008
    Posts
    2

    Re: GM965 Chipset, Blender, Open GL

    Okay, I just had a closer look at the readme.txt for the file I downloaded and installed, and sure enough, the driver I installed is the latest one,

    * Driver Revision: Production Version 14.32.3
    * Package: 43262
    *
    * Graphics: 6.14.10.4906
    * HDMI Audio: 5.10.0.1030
    *
    * December 28, 2007

    So my driver is completely up to date. I presume there's some setting I need to adjust to get this front buffer problem fixed. Any ideas?

    For what it's worth, my understanding is that this driver should support up to OpenGl 1.4, and that Blender requires 1.2.

  4. #4
    Junior Member Newbie
    Join Date
    Feb 2008
    Posts
    1

    Re: GM965 Chipset, Blender, Open GL

    I found a solution for me and my XP laptop with x3100 graphics:

    i downloaded newest vista driver for GM965 (Version 15.7.3)(LINK)
    make sure you download the zip-File.

    After downloading, open zip-Archive and copy the file
    ig4dev32.dll,
    which resides in the folder graphics into your blender folder.
    start blender
    now everything works fine. At least for me.

    hopefully this will help other people as well.


    EDIT:
    just found out, this makes Blender use GDI renderer, but at least i can work with it, for the time being

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •