Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 6 of 6

Thread: Catalyst 4.5 and glSlang == crash ?

  1. #1
    Senior Member OpenGL Guru
    Join Date
    Dec 2000
    Location
    Reutlingen, Germany
    Posts
    2,042

    Catalyst 4.5 and glSlang == crash ?

    Hi there

    I just installed the new Catalyst, just to find out, that my engine crashes with it.
    I tracked the bug down to glUseProgramObjectARB. The first time i call it, my app crashes showing some standard windows-error.
    Does anyone else have this problem? I am quite sure itīs not a bug on my side, because that code i use ever since the first glSlang driver was released.

    Jan.
    GLIM - Immediate Mode Emulation for GL3

  2. #2
    Junior Member Regular Contributor
    Join Date
    Jan 2003
    Posts
    113

    Re: Catalyst 4.5 and glSlang == crash ?

    no problems here.

    what kind of "standard windows-error"? Invalid memory access exception?
    Perhaps a problem with extension loading? With one catalyst version (change from ogl 1.4 to ogl 1.5 support) I had problems with a glew bug, not loading the extensions. But that was fixed some time ago...

    btw: Unfortunately there is still the gl_FragCoord bug and trivial loops are neither supported with the new catalyst version

  3. #3
    Senior Member OpenGL Guru
    Join Date
    Dec 2000
    Location
    Reutlingen, Germany
    Posts
    2,042

    Re: Catalyst 4.5 and glSlang == crash ?

    In english the error would be something like: "The instruction 'read' could not be executed, ..." sounds like a memory issue.

    I donīt use loops or the fragcoord.

    I do use glew, therefore i was pretty sure there is no problem with loading extensions. Iīll have to take a look into that.

    Thanks,
    Jan.
    GLIM - Immediate Mode Emulation for GL3

  4. #4
    Intern Contributor
    Join Date
    Apr 2004
    Location
    Sweden
    Posts
    67

    Re: Catalyst 4.5 and glSlang == crash ?

    The shader compile and links fine?

  5. #5
    Senior Member OpenGL Guru
    Join Date
    Dec 2000
    Location
    Reutlingen, Germany
    Posts
    2,042

    Re: Catalyst 4.5 and glSlang == crash ?

    Yeah, no problem there.
    GLIM - Immediate Mode Emulation for GL3

  6. #6
    Advanced Member Frequent Contributor yooyo's Avatar
    Join Date
    Apr 2003
    Location
    Belgrade, Serbia
    Posts
    872

    Re: Catalyst 4.5 and glSlang == crash ?

    Originally posted by valoh:

    what kind of "standard windows-error"? Invalid memory access exception?
    Perhaps a problem with extension loading? With one catalyst version (change from ogl 1.4 to ogl 1.5 support) I had problems with a glew bug, not loading the extensions. But that was fixed some time ago...
    Instead checking is extension supported and map extension entry points I'm using different approach. Scan all glext.h and wglext.h and try to map all entry points. Later.. just check is extension supported and use already maped entry points.

    yooyo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •