Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: OGSL Compiling errors

  1. #1
    Junior Member Newbie
    Join Date
    Jan 2004
    Location
    Spain
    Posts
    2

    OGSL Compiling errors

    Hi. I have been compiling OGSL programs in my Radeon 9800, but i don't understand why, now the OpenGL compiler engine launchs strange errors :

    ERROR: 0:5: 'gl_FragColor' : undeclared identifier

    This is a Built-in variable. How it's possible ??. Any suggestion ??

  2. #2
    Junior Member Regular Contributor
    Join Date
    May 2003
    Location
    Germany
    Posts
    229

    Re: OGSL Compiling errors

    1.) Make sure that you spell it correctly. gl_fragcolor isn't the same as gl_FragColor.

    2.) Where do you try to access that var? I hope it's in a fragment shader, cause it isn't (naturally) available in a vertex shader.

  3. #3
    Junior Member Newbie
    Join Date
    Jan 2004
    Location
    Spain
    Posts
    2

    Re: OGSL Compiling errors

    Hmmm... I am an idiot. I was compiling a fragment program as vertex program. Thank you very much. I want to be grateful for your response to you. Thanks again.

    Originally posted by PanzerSchreck:
    1.) Make sure that you spell it correctly. gl_fragcolor isn't the same as gl_FragColor.

    2.) Where do you try to access that var? I hope it's in a fragment shader, cause it isn't (naturally) available in a vertex shader.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •