Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: really need help

  1. #1
    Junior Member Newbie
    Join Date
    Feb 2004
    Location
    Moraga, CA , USA
    Posts
    13

    really need help

    This is the function declaration in my .h file
    int Bricks(GLcharARB *brickVertex, GLcharARB *brickFragment);

    This is the declaration in my brickshader.c
    int Bricks(GLcharARB *brickVertex, GLcharARB *brickFragment)

    These are the lines where I am having problems.
    glShaderSourceARB(brickVS, 1, &brickVertex, NULL);
    glShaderSourceARB(brickFS, 1, &brickFragment, NULL);

    and here is the error that I am getting
    error C2664: 'void (GLhandleARB,GLsizei,const GLcharARB ** ,const GLint *)' : cannot convert parameter 3 from 'GLcharARB **__w64 ' to 'const GLcharARB ** '
    Conversion loses qualifiers

    does anyone know what is causing this or how I can fix it.

    I really appreciate any help i can get
    thanks
    W

  2. #2
    Junior Member Newbie
    Join Date
    Feb 2004
    Location
    Moraga, CA , USA
    Posts
    13

    Re: really need help

    Ok so i got that fixed but now i have a ton of
    error LNK2001: unresolved external symbol "void (__stdcall* glVertexAttrib1fARB)(unsigned int,float)" (?glVertexAttrib1fARB@@3P6GXIM@ZA)

    actually all of my
    PFNGL...ARB
    extern PFNGL...ARB
    PADDR(PFN...
    commands have this error, i think that it is a problem with the PADDR in the main of the source code.
    I have a header file, a shader file, and a main file that contains my main and display...
    anyone know what fixes this problem. thank

    W

  3. #3
    Junior Member Newbie
    Join Date
    Feb 2004
    Location
    Moraga, CA , USA
    Posts
    13

    Re: really need help

    ok just fixed those now im just down to

    error LNK2019: unresolved external symbol _
    _ShadersBrick referenced in function _main

    and

    unresolved external symbol _ShaderSource referenced in function _main

    any ideas

    W

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •