Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 6 of 6

Thread: wglUseFontOutlines error

  1. #1
    Junior Member Newbie
    Join Date
    Mar 2004
    Posts
    3

    wglUseFontOutlines error

    This was posted a while ago on the advanced board. Does anyone know anything about the error 0x8 (out of memory error) caused by wglUseFontOutlines? I'm using a very simple call;

    if (wglUseFontOutlines(MainhDC, 0, 256, 256, 0.0f, 0.1f, WGL_FONT_POLYGONS, NULL) == FALSE) {
    ... etc ...

    this happens whatever I do to the numbers in the call, even if I reduce it to one single character or copy the example out of the MSDN website verbatim (with non-NULL final parameter). Something strange is going on.

    Surely this is common enough to have happened to plenty of other people? wglUseFontBitmaps works fine, and I have a nice graphics card (128Mb) and plenty of RAM so neither of those is a problem.

    Any solutions?

    Cheers,
    Col

  2. #2
    Junior Member Regular Contributor
    Join Date
    Mar 2004
    Posts
    143

    Re: wglUseFontOutlines error

    Hmmmm, strange.

    What operating system and what 3d card are you using?

    Does that happen when you run it on a different system?

    (I think it could be a driver related problem if you get my drift...)

  3. #3
    Junior Member Newbie
    Join Date
    Mar 2004
    Posts
    3

    Re: wglUseFontOutlines error

    Using Win2k (fully updated), GeForce4Ti4200. It *could* be a driver problem - I'll try instaling the latest ones.

    It's certainly very bizarre.

    Anyone else actually had this problem?

    Cheers,
    Col

  4. #4
    Junior Member Regular Contributor
    Join Date
    Mar 2004
    Posts
    143

    Re: wglUseFontOutlines error

    It may not be an driver related problem after all.

    I expierenced strange effects when:

    a.) The c: drive is almost full and windows cant extend the swap file anymore.

    b.) The local security policy for the logged in user was very restricted.

    Maybe a bit far fetched but worth checking.

  5. #5
    Junior Member Newbie
    Join Date
    Mar 2004
    Posts
    3

    Re: wglUseFontOutlines error

    Hi,

    It's not a driver problem - I just installed the newest ones. As for the other issues, my C: drive has 1.3Gb left and I'm logged in as administrator.

    This is extremely bizarre. And also very annoying as the workaround using open source libraries is a bit complicated.

    Cheers,
    Col

  6. #6
    Junior Member Newbie
    Join Date
    Aug 2002
    Posts
    21

    Re: wglUseFontOutlines error

    Hi Colin, I had exactly this error but some months ago now. If you can wait until tomorrow I will dig deep into my code to see if I left myself any hints From (dodgy) memory: are you calling it several times? I seem to remember being able to call it error free the first time only.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •