Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 6 of 6

Thread: I get this error when trying to play a Jedi Knight game...

  1. #1
    Junior Member Newbie
    Join Date
    Jun 2004
    Posts
    1

    I get this error when trying to play a Jedi Knight game...

    "GLW_StartOpenGL() - could not load OpenGL subsystem".

    Googling for information, it says I need to update my video drivers. But, I have what I think is the latest video driver for both machines I've tried to play the game on.

    Another suggestion was to come here.

    One machine has an ATI Radeon 9600 Pro. I don't know the card on the other, but, the drivers are 'supposed' to be updated.

    Gwen

  2. #2
    Junior Member Newbie
    Join Date
    Jul 2004
    Location
    Australia
    Posts
    1

    Re: I get this error when trying to play a Jedi Knight game...

    I got the exact same problem when first trying to play Jedi Knight: Jedi Academy. Which is to say I bought it today and am searching for what I can do about. If you have found anything useful, could you tell me pleeease? Or anyone else that can help of course.

    Thankyou

  3. #3
    Junior Member Newbie
    Join Date
    Aug 2004
    Posts
    4

    Re: I get this error when trying to play a Jedi Knight game...

    Originally posted by damnabilia:
    If you have found anything useful, could you tell me pleeease? Or anyone else that can help of course.
    I think, that you have this problem on Windows XP?
    If it is, you should download the newest display drivers from nvidia.com

  4. #4
    Junior Member Newbie
    Join Date
    Aug 2004
    Location
    Aus
    Posts
    7

    Re: I get this error when trying to play a Jedi Knight game...

    If you have this problem you may mant to add your graphics drivers (opengl32.dll and opengl.dll) to the main game directory. You may need to get new ones from the net.

  5. #5
    Junior Member Newbie
    Join Date
    Oct 2004
    Posts
    1

    Re: I get this error when trying to play a Jedi Knight game...

    THE SOLUTION FOR: GLW_StartOpenGL() - could not load OpenGL subsystem - WINDOWS XP AND WIN2K

    (2000)

    ---------------------------------------------
    English version:
    ---------------------------------------------

    First step: Go to WindowsUpdate and update your WINDOWS XP or WIN2K(I´m not bull****ing you, you

    are going to see why later). After, update your DirectX to the latest version, in my case, it was

    DirectX 9.0c. And also, get your latest Graphic cards drivers update. In my case, MSI GEFORCE

    FX5700 128 Mb I found 61.77 nvidia compatible drivers in MSI Live Update. Live Update comes with

    your Graphic card CD installer. You have to install it and update to the last utility version

    too. I updated the utility 3 times.

    Second step: That´s what solved the problem. In Windows explorer, go to your Windows XP directory

    (C:\WINDOWS), in Win2K, go to the WINNT directory (C:\WINNT). Click once on it (highlight it -

    blue). Now click on the lens figure (Search) or File> Windows> Search...

    Third step: In Windows XP, select "ALL FILES AND FOLDERS". And in the first line write this:

    opengl32.dll

    Fourth step: Click on Search button. If you have updated Windows XP you should see:

    opengl32.dll C:\WINDOWS\system32
    opengl32.dll C:\WINDOWS\ServicePackFiles\i386
    opengl32.dll C:\WINDOWS\SoftwareDistribution\Download\3ad72c83b f0dcc7aa380d88f91b0f627

    If you have updated Win2K you should see:

    opengl32.dll C:\WINNT\system32
    opengl32.dll C:\WINNT\ServicePackFiles\i386

    Fifth step: Now, copy the last modified opengl32.dll file , in my case, it was opengl32.dll from

    C:\WINDOWS\SoftwareDistribution\Download\3ad72c83b f0dcc7aa380d88f91b0f627 in Windows XP. In Win2K

    it was opengl32.dll from C:\WINNT\ServicePackFiles\i386.

    Sixth step: In my case, the game was: Jedi Knight: Jedi Academy. So, go to the folder:

    (C:\ProgramFiles\LucasArts\Star Wars Jedi Knight Jedi Academy) and paste the opengl32.dll that

    you´ve copied. Overwrite any file if necessary. Do the same in (C:\Program Files\LucasArts\Star

    Wars Jedi Knight Jedi Academy\GameData). Do the same in (C:\Arquivos de programas\LucasArts\Star

    Wars Jedi Knight Jedi Academy\GameData\Base). Do the same in (C:\Arquivos de

    programas\LucasArts\Star Wars Jedi Knight Jedi Academy\Install).
    In other games like Quake, etc.. copy de opengl32.dll file to all the folders. Do it because you

    usually dont know where the game is going to get the opengl library.

    Seventh step: RUN THE GAME AND HAVE FUN !!!!!!!!

    ----------------------------------------------
    Versao Brasileira/Portuguesa
    ----------------------------------------------

    Primeiro passo: Vá até o site do WindowsUpdate e atualize o seu Windows XP ou Windows 2000 (Não

    estou te sacaneando, você vai entender o porque de tudo depois). Após isso, atualiza o seu

    DirectX pra última versão, no meu caso, era a versão do DirectX 9.0c. E também, faz o download

    das atualizações dos últimos drivers da sua placa de vídeo. No meu caso, MSI GEFORCE FX5700 128

    Mb eu achei o driver 61.77 compatível com Nvidia no MSI Live update. Ele vem junto com o CD de

    instalação da tua placa. Você deve instalá-lo e atualizá-lo para última versão. Eu o atualizei 3

    vezes.

    Segundo passo: É isso que resolveu literalmente o problema.Através do Windows Explorer vai até o

    diretório do Windows XP (C:\WINDOWS), no Windows 2000, vai até o diretório WINNT (C:\WINNT).Deixe

    o diretório em "Highlight" clica nele uma vez que ele fica selecionado em azul (entendeu agora?

    hehehe..). Agora clica no desenho da lupa ou Arquivo> Windows> Pesquisar...

    Terceiro passo: No Windows XP, clique em "Todos os arquivos e pastas". No campo: "Todo ou parte

    do nome do arquivo", escreva: opengl32.dll

    Quarto passo: clique no botão "Pesquisar". Se você atualizou o Windows XP você deve encontrar:

    opengl32.dll C:\WINDOWS\system32
    opengl32.dll C:\WINDOWS\ServicePackFiles\i386
    opengl32.dll C:\WINDOWS\SoftwareDistribution\Download\3ad72c83b f0dcc7aa380d88f91b0f627

    Se você atualizou o Windows 2000 você verá:

    opengl32.dll C:\WINNT\system32
    opengl32.dll C:\WINNT\ServicePackFiles\i386

    Quinto passo: Agora copie (botao direito do mouse> copiar) o último arquivo opengl32.dll

    modificado (em, botao direito do mouse, propriedades, você encontra essa informação), no meu

    caso, era o opengl32.dll em

    C:\WINDOWS\SoftwareDistribution\Download\3ad72c83b f0dcc7aa380d88f91b0f627 no Windows XP. No

    Windows 2000 era o opengl32.dll do C:\WINNT\ServicePackFiles\i386.

    Sexto passo: No meu caso, o jogo era: Jedi Knight: Jedi Academy. Então, vai pro diretório

    (C:\ProgramFiles\LucasArts\Star Wars Jedi Knight Jedi Academy) e cole o opengl32.dll que você

    copiou. Sobreescreva o arquivo se necessário. Faça o mesmo em: (C:\Program Files\LucasArts\Star

    Wars Jedi Knight Jedi Academy\GameData). Faça o mesmo em: (C:\Arquivos de

    programas\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\Base). Faça o mesmo em:

    (C:\Arquivos de programas\LucasArts\Star Wars Jedi Knight Jedi Academy\Install).
    Em outros jogos como o Quake, etc... copie o arquivo opengl32.dll para todos os diretórios. Faça

    isso pois você geralmente não sabe aonde o jogo requisitará a biblioteca do opengl.

    Sétimo passo: RODE O JOGO E DIVIRTA-SE !!!!!!

  6. #6
    Junior Member Newbie
    Join Date
    Aug 2010
    Posts
    1

    Re: I get this error when trying to play a Jedi Knight game...

    Quote Originally Posted by 200mhz
    If you have this problem you may mant to add your graphics drivers (opengl32.dll and opengl.dll) to the main game directory. You may need to get new ones from the net.
    Guys, watch out for 200mhz's suggestions in games with PB enabled.
    I was banned from Enemy Territory because I copied the opengl32.dll and opengl.dll to the game directory as suggested here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •