Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 8 of 8

Thread: NVidia hardware acceleration under RedHat 7.0

  1. #1
    Guest

    NVidia hardware acceleration under RedHat 7.0

    Ok, so I believe I have everything installed as it should be, and nothing broke when I changed my XF86Config file to have Driver "nvidia" and Load "glx" in it (in their respective places of course). But, it doesn't appear that anything is being hardware accelerated. None of the 3D screensavers run at anywhere near hardware accelerated speeds.

    Any ideas would be much appreciated :-)
    -Fin

    PS. I've got an NVidia TNT2 video card.

  2. #2
    Member Regular Contributor
    Join Date
    Jun 2000
    Location
    Karlsruhe, Germany
    Posts
    360

    Re: NVidia hardware acceleration under RedHat 7.0

    Well, many linux opengl programs are linked against mesa (libMesaGL) and not against libGL. if your libMesaGL.so in /usr/lib isnt a symlink which points at NVIDIA's libGL nothing will happen (i mean hardware acceleration). Then you have to change the links to point at NVIDIA's driver.

    -Lev

  3. #3
    Junior Member Newbie
    Join Date
    Oct 2002
    Location
    Valencia
    Posts
    6

    Re: NVidia hardware acceleration under RedHat 7.0

    I have a RedHat6.1, and I have the nvidia drivers installed, but when some aplications start, the X11 hang down and i can`t do anything. I have a TNT2 M64 Graphics card.
    --
    Liso -Eadem Mutata Resurgo-
    Linux has you...

  4. #4
    Junior Member Newbie
    Join Date
    Nov 2000
    Location
    Warszawa, Poland
    Posts
    1

    Re: NVidia hardware acceleration under RedHat 7.0

    Fin:

    Please verify that you also load DRI module (e.g. Load "dri") and that NVidia kernel driver is loaded while running Xserver (e.g. issue 'cat /proc/modules | grep NVdriver' in xterm). To find out if you have things accelerated get yourself a precompiled version of 'glxinfo' at http://dri.sourceforge.net/resources/resources.html and look at http://dri.sourceforge.net/DRIuserguide.html to see what is wrong with your setup.

    Liso:

    Problem with TNT2 M64 can be resolved by modyfing NVdriver sources (look at file M64_USERS_README in NVIDIA_GLX-0.9-5), and if things still doesn't work, issue 'Option "NvAgp" "0"' into "Screen" section of your XF86Config file.

    regards,
    el czupi

  5. #5
    Guest

    Re: NVidia hardware acceleration under RedHat 7.0

    Originally posted by Fin:
    Ok, so I believe I have everything installed as it should be, and nothing broke when I changed my XF86Config file to have Driver "nvidia" and Load "glx" in it (in their respective places of course). But, it doesn't appear that anything is being hardware accelerated. None of the 3D screensavers run at anywhere near hardware accelerated speeds.

    Any ideas would be much appreciated :-)
    -Fin

    PS. I've got an NVidia TNT2 video card.

    if you use RH7.0 with XFree4.0, you must modify the filename /etc/X11/XF86Config-4 to take advantage of Hardware acceleration

  6. #6
    Junior Member Newbie
    Join Date
    Oct 2002
    Location
    Valencia
    Posts
    6

    Re: NVidia hardware acceleration under RedHat 7.0

    Hi again.
    Three or four days ago I installed the RH7.0 and I tried to install the NVdrivers.
    After lots of hours figthing versus NVdrivers & XF4, y finaly get acceleration from my TNT2 M64. I have recompiled the nvkernel with the patch for M64, I disable the agp, and when I launch a OGl aplication...
    {
    if(aplication.fullscreen=1)
    {
    run_the_GL_program();
    wait_15_or_20_secons_and_hang_up_the_PC();
    return 1;
    }
    else if (aplication.fullscreen=0)
    {
    do_something_strange();
    }

    void do_something_strange()
    {
    /*
    This function do things like run the program fine but when I move the window, the window move but the render is make in the same location
    */
    }

    Please can somebody help me????

    My next step will be upgrade to 2.4 kernel.
    --
    Liso -Eadem Mutata Resurgo-
    Linux has you...

  7. #7
    Junior Member Newbie
    Join Date
    Jun 2001
    Posts
    10

    Re: NVidia hardware acceleration under RedHat 7.0

    Liso,

    Go to /usr/lib and make sure that libGL.so and libGL.so.1 are both symlinks to libGL.so.1.0.5 and not to libGL.so.030300 (or something like that). The 1.0.5 belongs to the NVidia drivers package while the 030300 (or something like that -- i.e. looks like a date) is the one from Mesa. I had this problem when I first installed the new drivers. However, the above fixed that problem.

    hpsolo

  8. #8
    Junior Member Newbie
    Join Date
    Oct 2002
    Location
    Valencia
    Posts
    6

    Re: NVidia hardware acceleration under RedHat 7.0

    It works!!!!!!!!!!!
    And works better than Windows i get in the aplication 193 fps and in win9x i get 184 .


    Thanks hpsolo, thanks very much!!
    Now i can start to work mi RPG for Linux in 3D :P,
    I promise to send you a copy of it .
    --
    Liso -Eadem Mutata Resurgo-
    Linux has you...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •