Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: Quake3 in Linux

  1. #1
    Junior Member Newbie
    Join Date
    Jun 2000
    Location
    Sydney, NSW, Australia
    Posts
    1

    Quake3 in Linux

    I'm trying to get quake3 to run in Mandrake Linux. Ive got a Diamond Viper TNT2 and I have installed mesa 3.2. when i run quake3 i get: "Error: GLimp Init() - Could not load OpenGL subsystem"

    Is there something else i need to install?

    thanks.

  2. #2
    Intern Contributor
    Join Date
    Feb 2000
    Location
    Breda, Netherlands
    Posts
    58

    Re: Quake3 in Linux

    Hi!

    I can't remember for real, but I guess you just have to (re)move the libMesaVooDoo.so file in the quake dir and ln -s to your libGL.so or libMesaGL.so (which ever you use) and name it the libMesaVooDoo.so or something like that. And quake will allways load the voodoo lib, but doesn't notice the difference since all the calls it makes are in the other lib too.

    John

  3. #3
    Junior Member Newbie
    Join Date
    Apr 2000
    Location
    FRANCE
    Posts
    22

    Re: Quake3 in Linux

    Install Xfree4.0 with last Nvidia drivers.

    It's a pain, but it worth the troubles, it is almost fast as under Windo$...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •