Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: GLUT Problem

  1. #1
    Junior Member Newbie
    Join Date
    Apr 2000
    Location
    Pickering, Ontario, Canada
    Posts
    3

    GLUT Problem

    I downloaded glut for Windows 9x (I have '98b), and put all the libs, and dll's in the LIB folder of my VC++ 6.0 directory. However, now I can't compile any of my OpenGL applications using GLUT, nor ANY OpenGL program using that compiler! I'm in desperate need for help... can anyone give me a hand?
    Programming::~Fredric(const Annoy_ance)

  2. #2
    Junior Member Newbie
    Join Date
    Mar 2000
    Location
    Chicago, IL, USA
    Posts
    6

    Re: GLUT Problem

    There are a few things I would try if I were you:

    Click on Project > Settings > Link Tab, then, under the Object/Library Modules textbox, scroll all the way to the right and add glut32.lib, just how all the other modules are written, just spaces separating them, and nothing special. And, make sure the directory you have the library is defined in the list of include directories...to edit this list go to Tools > Options > Directories Tab. Look at your library directories, and make sure glut32.lib is in one of those directories, or add whatever directory it is currently in.

    Also, this may seem like given, but you may want to check it anyway; make sure when you include the header, you include it from gl subdirectory, and that glut.h is in your gl subdirectory.

    Last thing: try putting glut32.dll in the same directory the project file and source code is, and make sure glut32.dll is in your windows/system directory.

    Thats all I can think of for right now...if I think of something I'll post another message here, but I'd be interested to know exactly what the error is you are getting if you want to post it here.

    -Alan

  3. #3
    Junior Member Newbie
    Join Date
    Apr 2000
    Location
    San Francisco, CA, USA
    Posts
    22

    Re: GLUT Problem

    It might be better for you to put all dll in the system folder

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •