Part of the Khronos Group
OpenGL.org

The Industry's Foundation for High Performance Graphics

from games to virtual reality, mobile phones to supercomputers

Results 1 to 3 of 3

Thread: Color-Index Mode @ WinNT

  1. #1
    Guest

    Color-Index Mode @ WinNT

    Trying to get 'aaindex.c' (Redbook Example 6-4)to run on a WinNT station, I receive the message: "GLUT: Fatal Error in (path...).exe: visual with necessary capabilities not found".
    Using: "glutInitDisplayMode (GLUT_SINGLE | GLUT_RGB);" instead of: "... GLUT_INDEX);",
    it compiles and runs normally. What am I doing wrong and what is a "visual"?

  2. #2
    Intern Contributor
    Join Date
    Feb 2000
    Location
    France
    Posts
    55

    Re: Color-Index Mode @ WinNT

    Maybe you should try with RGBA instead of RGB (i got som problems with that on several machines).
    If it doesn't work, then your graphic capabilities are just too poor for your programs. What's you video card ? maybe you must change it.

  3. #3
    Intern Contributor
    Join Date
    Feb 2000
    Location
    Stafford, UK
    Posts
    60

    Re: Color-Index Mode @ WinNT

    I have had this problem as well with the color index example, im using a Riva TNT card with 16MB Ram. Would it be a hardware problem? Oh and im running it in 98 not NT, and im still getting the same error message.

    Any Ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •